matrix-gui-e: bump PR for init file fixes
[openembedded.git] / recipes / puzzles / puzzles_r7436.bb
blobd8bc086cfc69f9cea71f2771ebfe1bf20f852a3f
2 DEPENDS = "gtk+ libxt"
4 PR = "r3"
6 SVN_REV = "${@bb.data.getVar('PV',d,1).replace('r', '')}"
8 SRC_URI = "svn://svn.tartarus.org/sgt;module=puzzles;proto=svn;rev=${SVN_REV} \
9 file://game.png"
11 S = "${WORKDIR}/puzzles"
13 do_configure () {
14 ./mkfiles.pl
17 do_compile_prepend = " \
18 export XLDFLAGS='${LDFLAGS} `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --libs`'; \
19 export CFLAGS='${CFLAGS} -I./ `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --cflags`'; "
21 FILES_${PN} = "${prefix}/games/* ${datadir}/applications/* ${datadir}/pixmaps"
22 FILES_${PN}-dbg += "${prefix}/games/.debug"
24 do_install () {
25 rm -rf ${D}/*
26 export prefix=${D}
27 export DESTDIR=${D}
28 install -d ${D}/${prefix}/
29 install -d ${D}/${prefix}/games/
30 oe_runmake install
32 install -d ${D}/${datadir}/
33 install -d ${D}/${datadir}/applications/
34 install -d ${D}/${datadir}/pixmaps/
36 install ${WORKDIR}/game.png ${D}/${datadir}/pixmaps/
38 cd ${D}/${prefix}/games
39 for prog in *; do
40 if [ -x $prog ]; then
41 echo "making ${D}/${datadir}/applications/$prog.desktop"
42 cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
43 [Desktop Entry]
44 Encoding=UTF-8
45 Name=$prog
46 Exec=${prefix}/games/$prog
47 Icon=game.png
48 Terminal=false
49 Type=Application
50 Categories=Game
51 StartupNotify=true
52 SingleInstance=true
53 STOP
55 done