1 DESCRIPTION
= "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
6 # download required binary distribution from
:
7 # http
://software
-dl.ti.com
/dsps
/dsps_public_sw
/sdo_sb
/targetcontent
/gfxsdk
/latest
/index_FDS.html
8 # see libgles
-omap3.inc
for detailed installation instructions
10 TI_BIN_UNPK_CMDS
="Y: qY:workdir:Y"
11 require ..
/ti
/ti
-eula
-unpack.inc
15 BINFILE
:= "OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin"
17 SRC_URI
= "http://install.source.dir.local/OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin \
18 file://0001-Compile-fixes-for-recent-kernels.patch \
20 S
= "${WORKDIR}/OMAP35x_Graphics_SDK_${SGXPV}/GFX_Linux_KM"
28 MAKE_TARGETS
= " BUILD=${PVRBUILD}"
31 mkdir
-p $
{D
}/lib
/modules
/$
{KERNEL_VERSION
}/kernel
/drivers
/gpu
/pvr
33 $
{S
}/services4
/3rdparty
/dc_omap3430_linux
/omaplfb.ko \
34 $
{S
}/services4
/3rdparty
/bufferclass_ti
/bufferclass_ti.ko \
35 $
{D
}/lib
/modules
/$
{KERNEL_VERSION
}/kernel
/drivers
/gpu
/pvr