matrix-gui-e: bump PR for init file fixes
[openembedded.git] / recipes / powervr-drivers / omap3-sgx-modules_1.4.14.2514.bb
blob6f6e073cde731ab7b0f93509c75a7e4e9729305b
1 DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2 LICENSE = "GPLv2"
4 PR_append = "a"
6 # download required binary distribution from:
7 # http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/latest/index_FDS.html
8 # see libgles-omap3.inc for detailed installation instructions
10 TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
11 require ../ti/ti-eula-unpack.inc
13 SGXPV = "3_01_00_02"
14 IMGPV = "1.4.14.2514"
15 BINFILE := "OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin"
17 SRC_URI = "http://install.source.dir.local/OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin \
18 file://0001-Compile-fixes-for-recent-kernels.patch \
20 S = "${WORKDIR}/OMAP35x_Graphics_SDK_${SGXPV}/GFX_Linux_KM"
22 inherit module
24 PVRBUILD = "release"
26 PACKAGE_STRIP = "no"
28 MAKE_TARGETS = " BUILD=${PVRBUILD}"
30 do_install() {
31 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
32 cp ${S}/pvrsrvkm.ko \
33 ${S}/services4/3rdparty/dc_omap3430_linux/omaplfb.ko \
34 ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
35 ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr