matrix-gui-e: bump PR for init file fixes
[openembedded.git] / recipes / howl / howl_1.0.0.bb
blobfa2eb343fb0d1f8a69d80876f474439ee180c3a9
1 SRC_URI = "http://www.porchdogsoft.com/download/howl-${PV}.tar.gz \
2 file://posix.patch;striplevel=0 \
3 file://configure.patch;striplevel=0 \
4 file://mdnsresponder.init"
5 LICENSE = "howl"
7 PR = "r2"
9 INITSCRIPT_NAME = "mdnsresponder"
10 INITSCRIPT_PARAMS = "defaults"
12 PACKAGES += "libhowl libmdnsresponder"
14 FILES_${PN} = "${bindir} ${sbindir} ${sysconfdir}"
15 FILES_libhowl = "${libdir}/libhowl.so.*"
16 FILES_libmdnsresponder = "${libdir}/libmDNSResponder.so.*"
17 FILES_${PN}-doc += "${datadir}/howl/help"
19 do_install_append() {
20 install -d ${D}${sysconfdir}/init.d
21 install -d ${D}${sbindir}
22 install -m 0755 ${WORKDIR}/mdnsresponder.init ${D}${sysconfdir}/init.d/mdnsresponder
23 # Debian puts it here, so let's do the same
24 mv ${D}${bindir}/mDNSResponder ${D}${sbindir}
27 inherit autotools update-rc.d
30 SRC_URI[md5sum] = "c389d3ffba0e69a179de2ec650f1fdcc"
31 SRC_URI[sha256sum] = "6f0145ab1802092308adeb8dfa285f58e104f0822fa266e5ec97e9d27f0e1923"