matrix-gui-e: bump PR for init file fixes
[openembedded.git] / recipes / hfsutils / hfsutils_3.2.6.bb
blob708ad84a17dd298d910abaad6d0c35cfdd7550a5
1 DESCRIPTION = "HFS file system utilities"
2 SECTION = "base"
3 LICENSE = "GPL"
4 PR = "r2"
6 inherit autotools pkgconfig
8 SRC_URI = "ftp://ftp.mars.org/pub/hfs/hfsutils-3.2.6.tar.gz \
9 file://hfsutils-3.2.6-errno.patch \
10 file://largerthan2gb.patch \
13 do_configure () {
14 oe_runconf --disable-x
17 do_compile () {
18 oe_runmake
19 cd hfsck; oe_runmake
22 do_install () {
23 install -d ${D}/${bindir}
24 install -m 755 hfsutil ${D}/${bindir}/hfsutil
25 install -m 755 hfsck/hfsck ${D}/${bindir}/hfsck
27 for util in hattrib hcd hcopy hdel hdir hformat \
28 his hmkdir hmount hpwd hrename hrmdir \
29 humount hvol; do
30 ln -sf hfsutil ${D}/${bindir}/${util}
31 done
34 SRC_URI[md5sum] = "fa572afd6da969e25c1455f728750ec4"
35 SRC_URI[sha256sum] = "bc9d22d6d252b920ec9cdf18e00b7655a6189b3f34f42e58d5bb152957289840"