matrix-gui-e: bump PR for init file fixes
[openembedded.git] / recipes / gnome / metacity_2.30.0.bb
blobd6028799aad5729d5d5cae1e84604209e7f3e268
1 SECTION = "x11/wm"
2 DESCRIPTION = "Metacity is the boring window manager for the adult in you."
3 LICENSE = "GPL"
4 DEPENDS = "libcanberra libwnck startup-notification gtk+ gconf gdk-pixbuf-csource-native"
6 inherit gnome update-alternatives
8 SRC_URI += "file://crosscompile.patch "
10 SRC_URI[archive.md5sum] = "7c8a4c8f3b667efcc60f286adb445d4c"
11 SRC_URI[archive.sha256sum] = "5c4e2af2216de022181f692f15427361a1dae3d30756ef89b97a11ff5bd50b22"
13 EXTRA_OECONF += "--disable-verbose \
14 --disable-xinerama \
15 --without-introspectiom \
18 do_configure_prepend() {
19 sed -i -e 's:$ZENITY:$NOZENITY:g' -e 's:-Werror::g' ${S}/configure.in
22 EXTRA_OEMAKE = ' STAGING_INCDIR_NATIVE="${STAGING_INCDIR_NATIVE}" STAGING_LIBDIR_NATIVE="${STAGING_LIBDIR_NATIVE}"'
24 ALTERNATIVE_NAME = "x-window-manager"
25 ALTERNATIVE_LINK = "${bindir}/x-window-manager"
26 ALTERNATIVE_PATH = "${bindir}/metacity"
27 ALTERNATIVE_PRIORITY = "30"
29 RDEPENDS_${PN} = "zenity"
30 FILES_${PN} += "${datadir}/themes ${datadir}/gnome*"