matrix-gui-e: bump PR for init file fixes
[openembedded.git] / recipes / gnome / goffice_0.8.1.bb
blob6ef4fbf714d0c9fc80a3984e146b1054515d9f85
1 DESCRIPTION="Gnome Office Library"
2 LICENSE="GPLv2"
4 DEPENDS="glib-2.0 gtk+ pango cairo libgnomeprint libgsf libglade libpcre libxml2 libart-lgpl"
6 inherit gnome pkgconfig
8 SRC_URI += " file://c99math.patch \
9 file://nodolt.patch "
11 SRC_URI[archive.md5sum] = "fdc43c5e04f6ead55bebc034c1d34296"
12 SRC_URI[archive.sha256sum] = "9e2497956349fee8e6ec34a13160635455ead79a5118cbe61cb387e4cfd2b31e"
14 FILES_${PN}-dbg += "${libdir}/goffice/${PV}/plugins/*/.debug"
16 RRECOMMENDS_${PN} = " \
17 goffice-plugin-plot-barcol \
18 goffice-plugin-plot-distrib \
19 goffice-plugin-plot-pie \
20 goffice-plugin-plot-radar \
21 goffice-plugin-plot-surface \
22 goffice-plugin-plot-xy \
23 goffice-plugin-reg-linear \
24 goffice-plugin-reg-logfit \
25 goffice-plugin-smoothing \
28 FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*${SOLIBS} \
29 ${sysconfdir} ${sharedstatedir} ${localstatedir} \
30 ${base_bindir}/* ${base_sbindir}/* \
31 ${base_libdir}/*${SOLIBS} \
32 ${datadir}/${PN} \
33 ${datadir}/pixmaps ${datadir}/applications \
34 ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
35 ${libdir}/bonobo/servers"
37 PACKAGES_DYNAMIC = "goffice-plugin-*"
39 python populate_packages_prepend () {
40 goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins/', d)
42 do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True)