matrix-gui-e: bump PR for init file fixes
[openembedded.git] / recipes / gnome / gnome-vfs_2.22.0.bb
blob5ce0648672ec4af62262383cd7f38a6321eafd50
1 LICENSE = "GPL"
2 DEPENDS = "libxml2 gconf gnutls avahi dbus dbus-glib bzip2 gnome-mime-data zlib"
3 RRECOMMENDS_${PN} = "gnome-vfs-plugin-file shared-mime-info"
4 # Some legacy packages will require gnome-mime-data to be installed, but use of
5 # it is deprecated.
6 PR = "r2"
8 inherit gnome
10 SRC_URI += "file://gconftool-lossage.patch \
11 file://gnome-vfs-no-kerberos.patch;striplevel=0"
13 # This is to provide compatibility with the gnome-vfs DBus fork
14 PROVIDES = "gnome-vfs-plugin-dbus"
15 RREPLACES_${PN} = "gnome-vfs-dbus"
17 EXTRA_OECONF = " \
18 --disable-openssl \
19 --enable-gnutls \
20 --enable-avahi \
21 --with-samba-includes=${STAGING_INCDIR} \
24 FILES_${PN} += "${libdir}/vfs ${datadir}/dbus-1/services"
25 FILES_${PN}-dbg += "${libdir}/gnome-vfs-2.0/modules/.debug"
26 FILES_${PN}-dev += "\
27 ${libdir}/gnome-vfs-2.0/include \
28 ${libdir}/gnome-vfs-2.0/modules/*.a \
29 ${libdir}/gnome-vfs-2.0/modules/*.la \
31 FILES_${PN}-doc += "${datadir}/gtk-doc"
33 PACKAGES_DYNAMIC = "gnome-vfs-plugin-*"
35 python populate_packages_prepend () {
36 print bb.data.getVar('FILES_gnome-vfs', d, 1)
38 plugindir = bb.data.expand('${libdir}/gnome-vfs-2.0/modules/', d)
39 do_split_packages(d, plugindir, '^lib(.*)\.so$', 'gnome-vfs-plugin-%s', 'GNOME VFS plugin for %s')
44 SRC_URI[archive.md5sum] = "369105fd82cb99e69e63acab8f3b89b7"
45 SRC_URI[archive.sha256sum] = "622cf50cefa2c4187e0a23f29d665f010f7a0815864fc35a61caefd5a7d4ebb1"