matrix-gui-e: bump PR for init file fixes
[openembedded.git] / recipes / gnome / gnome-bluetooth_git.bb
blobcf490971e452638d3b5f243dba1fbad02bea2e3a
1 LICENSE = "GPL"
2 SECTION = "x11/gnome"
4 DEFAULT_PREFERENCE = "-1"
6 inherit autotools gnome pkgconfig
8 SRC_URI = "git://git.gnome.org/gnome-bluetooth;branch=gnome-2-28;protocol=git \
9 file://gtk-doc.make \
12 S = "${WORKDIR}/git"
14 SRCREV = "2d23ec20fa8f8299e93beea849bc8670aa2c7c69"
15 PV = "2.28.6"
16 PR = "r0"
17 PR_append = "+gitr${SRCREV}"
19 DEPENDS = "geoclue obexd gconf gtk+ dbus-glib libunique libnotify hal bluez4 gnome-keyring"
20 RRECOMMENDS_${PN} += "obexd"
21 RCONFLICTS_${PN} = "bluez-gnome"
23 do_configure_prepend() {
24 cp ${WORKDIR}/gtk-doc.make ${S}/
25 sed -i -e s:docs::g ${S}/Makefile.am
26 sed -i -e s:gnome-bluetooth/plugins/:gnome-bluetooth/plugins:g ${S}/lib/plugins/Makefile.am
27 echo "EXTRA_DIST = version.xml" > gnome-doc-utils.make
30 # Todo: automagic plugin splitting
32 FILES_${PN}-dbg += "${libdir}/gnome-bluetooth/plugins/.debug"