4 DEFAULT_PREFERENCE
= "-1"
6 inherit autotools gnome pkgconfig
8 SRC_URI
= "git://git.gnome.org/gnome-bluetooth;branch=gnome-2-28;protocol=git \
14 SRCREV
= "2d23ec20fa8f8299e93beea849bc8670aa2c7c69"
17 PR_append
= "+gitr${SRCREV}"
19 DEPENDS
= "geoclue obexd gconf gtk+ dbus-glib libunique libnotify hal bluez4 gnome-keyring"
20 RRECOMMENDS_$
{PN
} += "obexd"
21 RCONFLICTS_$
{PN
} = "bluez-gnome"
23 do_configure_prepend
() {
24 cp $
{WORKDIR
}/gtk
-doc.make $
{S
}/
25 sed
-i
-e s
:docs
::g $
{S
}/Makefile.am
26 sed
-i
-e s
:gnome
-bluetooth
/plugins
/:gnome
-bluetooth
/plugins
:g $
{S
}/lib
/plugins
/Makefile.am
27 echo
"EXTRA_DIST = version.xml" > gnome
-doc
-utils.make
30 # Todo
: automagic plugin splitting
32 FILES_$
{PN
}-dbg
+= "${libdir}/gnome-bluetooth/plugins/.debug"