matrix-gui-e: bump PR for init file fixes
[openembedded.git] / recipes / gd / gd_2.0.21.bb
blobf081079b022d6fa483c717c3e53c9cc30c76bb13
1 SECTION = "libs"
2 LICENSE = "GD"
3 DESCRIPTION = "gd is a library used to create PNG, JPEG, or WBMP images."
4 DEPENDS = "libpng jpeg zlib"
6 SRC_URI = "http://www.boutell.com/gd/http/gd-${PV}.tar.gz"
7 S = "${WORKDIR}/gd-${PV}"
9 inherit autotools gettext
11 EXTRA_OECONF += " --with-zlib=${STAGING_LIBDIR}/.. \
12 --with-png=${STAGING_LIBDIR}/.. \
13 --with-jpeg=${STAGING_LIBDIR}/.. \
14 --without-xpm"
16 headers = "gd.h gdcache.h gd_io.h gdfx.h gdfontmb.h \
17 gdfontg.h gdfontl.h gdfonts.h gdfontt.h"
19 do_stage () {
20 oe_libinstall -so -a libgd ${STAGING_LIBDIR}/
21 for i in ${headers}; do
22 install -m 0644 $i ${STAGING_INCDIR}/
23 done
26 SRC_URI[md5sum] = "3134158635f5048dba99281c6b712a54"
27 SRC_URI[sha256sum] = "c3b8b7b57019927dad40870c379eecfa6389443f7e2096aa0157a0224d400da1"