initscripts-shr: remove devtmpfs initscript for palmpre machine
[openembedded.git] / recipes / linux / linux-mtx-3_2.6.15.4.bb
blob32e57cce941bfe353ff83df599f1cdd4a36ebb1b
1 DESCRIPTION = "Linux kernel for MTX-3 (Surfbox3)"
2 HOMEPAGE = "http://meshcube.org/meshwiki/"
3 LICENSE = "GPLv2"
4 KV = "${PV}"
5 PR = "r12"
7 inherit kernel
8 # therefore
9 # PROVIDES = "virtual/kernel"
11 DEPENDS = "u-boot"
12 RDEPENDS_${PN} = "mtd-utils"
14 SRC_URI += "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${KV}.tar.bz2;name=kernel \
15 file://00-mtx-3.diff \
16 file://01-verbose-and-fatal-mkuboot.diff \
17 file://defconfig-mtx-3"
19 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/linux-mtx-3-${KV}"
21 S = "${WORKDIR}/linux-${KV}"
24 COMPATIBLE_HOST = "arm.*-linux"
25 COMPATIBLE_MACHINE = "mtx-3"
27 # overriding default target 'zImage' with U-Boot-Image
28 # (note: uImage depends on zImage)
29 # U-Boot's "mkimage" is required for this to work
30 KERNEL_IMAGETYPE = "uImage"
32 # overriding default 'boot'
33 KERNEL_IMAGEDEST = "tmp"
35 XIP_PHYS_ADDR = "0x00080000"
37 MTX_KERNEL_NON_PCI_OHCI = "no"
39 PACKAGE_ARCH = "mtx-3"
41 do_configure_prepend() {
42 install -m 0644 ${WORKDIR}/defconfig-mtx-3 ${S}/.config
43 if [ "x${MTX_KERNEL_NON_PCI_OHCI}" = "xyes" ]; then
44 echo "CONFIG_USB_NON_PCI_OHCI=y" >> ${S}/.config
48 do_compile() {
50 kernel_do_compile
52 # set CONFIG_XIP_KERNEL=y and CONFIG_XIP_PHYS_ADDR=xxxx if commented out, else append it
53 # sed -i -e "s/^[# ]*CONFIG_XIP_KERNEL.*/CONFIG_XIP_KERNEL=y/" \
54 # -e "s/^[# ]*CONFIG_XIP_PHYS_ADDR.*/CONFIG_XIP_PHYS_ADDR=${XIP_PHYS_ADDR}/" .config
55 # grep -q "^CONFIG_XIP_PHYS_ADDR=" .config || echo "CONFIG_XIP_PHYS_ADDR=${XIP_PHYS_ADDR}" >>.config
57 # oe_runmake xipImage CC="arm-linux-gcc " LD="arm-linux-ld " ARCH="arm"
61 # FIXME: we need to find out the proper names and kernel image formats
62 # used / needed here and then fix the following ...
65 pkg_postinst_kernel() {
66 if test "x$D" != "x"; then
67 exit 1
68 else
69 if test -e /tmp/zImage.flash-${KV}; then
70 echo "*** flashing kernel ***"
71 flashcp -v /tmp/zImage.flash-${KV} /dev/mtd/2
72 echo "*** done. please reboot ***"
77 FILES_kernel += " /tmp"
79 do_deploy() {
80 install -d ${DEPLOY_DIR_IMAGE}
82 # uncompressed Image
83 install -m 0644 arch/arm/boot/Image ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_NAME}
85 # xip is probably not very useful for us - text segment reading may be slow on flash and we have enough ram
86 # install -m 0644 arch/arm/boot/xipImage ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_NAME}.xip
88 # old mtx-2 mips
89 #install -m 0644 arch/mips/boot/mtx-3.flash.srec ${DEPLOY_DIR}/images/${KERNEL_IMAGE_NAME}.flash.srec
90 #install -m 0644 arch/mips/boot/mtx-3.srec ${DEPLOY_DIR}/images/${KERNEL_IMAGE_NAME}.ram.srec
93 SRC_URI[kernel.md5sum] = "cee7c554cec949926cf524ee1def88c9"
94 SRC_URI[kernel.sha256sum] = "8430e13b08bbfce7963a138658d2192077abce097f210490767f34c8e9cbaa9f"