initscripts-shr: remove devtmpfs initscript for palmpre machine
[openembedded.git] / recipes / linux / linux-jlime-jornada7xx_2.6.34+git.bb
blob006b6091d136430dbc042d758695b5291c42336a
1 SECTION = "kernel"
2 DESCRIPTION = "JLime Linux kernel for Arm based Jornada 7xx"
3 LICENSE = "GPLv2"
4 PR = "r0"
6 COMPATIBLE_HOST = "arm.*-linux"
7 COMPATIBLE_MACHINE = "jornada7xx"
9 SRC_URI = "file://defconf_jlime"
11 S = "${WORKDIR}/linux-hpc"
13 inherit kernel
15 ARCH = "arm"
17 FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
19 do_fetch () {
20 cd ${WORKDIR}
21 [ -d linux-hpc ] && {
22 cd linux-hpc
23 git pull
24 } || {
25 git clone git://git.kernel.org/pub/scm/linux/kernel/git/kristoffer/linux-hpc.git
26 cd linux-hpc
27 # written individual do_fetch function because I don't know how to do this in SRC_URI:
28 git checkout --track -b v2.6.34-hpc origin/v2.6.34-hpc
29 git checkout v2.6.34-hpc
33 do_configure_prepend() {
34 install -m 0644 ${WORKDIR}/defconf_jlime ${S}/.config