initscripts-shr: remove devtmpfs initscript for palmpre machine
[openembedded.git] / recipes / gnuchess / fltk-chess_0.5.bb
blob5df4771117aaa93b947f71435084cf0c79950c15
1 DESCRIPTION = "fltk-chess is a frontend for the Gnuchess chess playing engine."
2 AUTHOR = "Andreas Holzer <a.holzer@cheese.at>"
3 SECTION = "x11/games"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 DEPENDS = "fltk"
7 RDEPENDS_${PN} = "gnuchess"
8 PR = "r1"
11 SRC_URI = "http://members.cheese.at/woody/fltk-chess/fltk-chess-${PV}.tgz \
12 file://fix_cast_error_and_gnuchess_exec.patch \
13 file://fltk-chess.desktop"
14 S = "${WORKDIR}/fltk-chess/"
17 do_compile() {
18 `fltk-config --cxx --cxxflags --ldflags --use-images` -o fltk-chess \
19 fltk-chess.cxx
22 do_install() {
23 install -d ${D}${bindir}
24 install -d ${D}${datadir}/pixmaps/fltk-chess/
25 install -d ${D}${datadir}/applications/
26 install -m 0755 ${S}/fltk-chess ${D}${bindir}
27 install -m 0644 ${S}/bitmaps/*.pnx ${D}${datadir}/pixmaps/fltk-chess/
28 install -m 0644 ${S}/bitmaps/{user,computer}.png \
29 ${D}${datadir}/pixmaps/fltk-chess/
30 install -m 0644 ${S}/bitmaps/fltk-chess.png ${D}${datadir}/pixmaps/
31 install -m 0644 ${WORKDIR}/fltk-chess.desktop ${D}${datadir}/applications/
36 SRC_URI[md5sum] = "ee34788a2dc9fdc088a6dc66c31eba34"
37 SRC_URI[sha256sum] = "c789b355d0ba03b018513c3904bba6d6fab01b3a83a460fbe1b20a79052f46a4"