initscripts-shr: remove devtmpfs initscript for palmpre machine
[openembedded.git] / recipes / gd / gd_2.0.22.bb
blob78e4811255aab17f7bbc1bef53e170c83a50b953
1 SECTION = "libs"
2 LICENSE = "GD"
3 DESCRIPTION = "gd is a library used to create PNG, JPEG, or WBMP images."
4 DEPENDS = "libpng jpeg zlib"
5 PR = "r1"
7 SRC_URI = "http://www.boutell.com/gd/http/gd-${PV}.tar.gz"
8 S = "${WORKDIR}/gd-${PV}"
10 inherit autotools binconfig gettext
12 EXTRA_OECONF += " --with-zlib=${STAGING_LIBDIR}/.. \
13 --with-png=${STAGING_LIBDIR}/.. \
14 --with-jpeg=${STAGING_LIBDIR}/.. \
15 --without-xpm"
17 headers = "gd.h gdcache.h gd_io.h gdfx.h gdfontmb.h \
18 gdfontg.h gdfontl.h gdfonts.h gdfontt.h"
20 do_stage () {
21 oe_libinstall -so -a libgd ${STAGING_LIBDIR}/
22 for i in ${headers}; do
23 install -m 0644 $i ${STAGING_INCDIR}/
24 done
27 SRC_URI[md5sum] = "e1a41daf3bfc221afaf56751dc506f95"
28 SRC_URI[sha256sum] = "e6bff5c00d7d93bade78535573494673f581118c38a8ca13c3afd63809335ba0"