sqlite: Merge target and native recipe using BBCLASSEXTEND, Remove native recipe
[openembedded.git] / classes / xfce46.bbclass
blobc24dfa4d8c7fb330307d1e8ab147d6b20303fcae
1 # xfce46.bbclass
3 # Global class to help maintain XFCE 4.6.* packages
5 HOMEPAGE = "http://www.xfce.org"
6 LICENSE = "LGPLv2"
8 DEPENDS += "startup-notification"
10 SECTION ?= "x11/xfce"
12 XFCE_VERSION = ${PV}
14 SRC_URI = "http://mocha.xfce.org/archive/src/xfce/${PN}/${@'${PV}'[0:3]}/${PN}-${PV}.tar.bz2"
16 inherit autotools gtk-icon-cache pkgconfig
18 AUTOTOOLS_STAGE_PKGCONFIG = "1"
20 EXTRA_OECONF += "--with-pluginsdir=${libdir}/xfce4/panel-plugins/"
22 # FIXME:  Put icons in their own package too?
24 FILES_${PN} += "${datadir}/icons/* ${datadir}/applications/* ${libdir}/xfce4/modules/*.so*"
25 FILES_${PN}-doc += "${datadir}/xfce4/doc"
27 FILES_${PN}-dev += "${libdir}/xfce4/*/*.la"
28 FILES_${PN}-dbg += "${libdir}/xfce4/*/.debug"