1 # IceCream distributed compiling support
3 # Stages directories with symlinks from gcc/g++ to icecc, for both
4 # native and cross compilers. Depending on each configure or compile,
5 # the directories are added at the head of the PATH list and ICECC_CXX
8 # For the cross compiler, creates a tar.gz of our toolchain and sets
9 # ICECC_VERSION accordingly.
11 #The class now handles all 3 different compile 'stages' (i.e native ,cross-kernel and target) creating the
12 #necessary enviroment tar.gz file to be used by the remote machines.
13 #It also supports meta-toolchain generation
15 #If ICECC_PATH is not set in local.conf then the class will try to locate it using 'which'
16 #but nothing is sure ;)
18 #If ICECC_ENV_EXEC is set in local.conf should point to the icecc-create-env script provided by the user
19 #or the default one provided by icecc-create-env.bb will be used
20 #(NOTE that this is a modified version of the script need it and *not the one that comes with icecc*
22 #User can specify if specific packages or packages belonging to class should not use icecc to distribute
23 #compile jobs to remote machines, but handled localy, by defining ICECC_USER_CLASS_BL and ICECC_PACKAGE_BL
24 #with the appropriate values in local.conf
25 #########################################################################################
26 #Error checking is kept to minimum so double check any parameters you pass to the class
27 ###########################################################################################
30 def icc_determine_gcc_version(gcc):
32 Hack to determine the version of GCC
34 'i686-apple-darwin8-gcc-4.0.1 (GCC) 4.0.1 (Apple Computer, Inc. build 5363)'
36 return os.popen("%s --version" % gcc ).readline().split()[2]
38 def create_cross_env(bb,d):
40 Create a tar.bz2 of the current toolchain
42 # Constin native-native compilation no environment needed if
43 # host prefix is empty (let us duplicate the query for ease)
44 prefix = bb.data.expand('${HOST_PREFIX}', d)
48 import tarfile, socket, time
49 ice_dir = bb.data.expand('${CROSS_DIR}', d)
50 staging_dir = bb.data.expand('${STAGING_DIR_TARGET}', d)
51 prefix = bb.data.expand('${HOST_PREFIX}' , d)
52 distro = bb.data.expand('${DISTRO}', d)
53 target_sys = bb.data.expand('${TARGET_SYS}', d)
54 target_prefix = bb.data.expand('${TARGET_PREFIX}', d)
55 float = bb.data.getVar('TARGET_FPU', d) or "hard"
56 name = socket.gethostname()
58 # Stupid check to determine if we have built a libc and a cross
61 os.stat(os.path.join(staging_dir, 'usr', 'lib', 'libstdc++.so'))
62 os.stat(os.path.join(ice_dir, 'bin', "%s-g++" % target_sys))
63 except: # no cross compiler built yet
66 VERSION = icc_determine_gcc_version( os.path.join(ice_dir,"bin","%s-g++" % target_sys) )
67 cross_name = prefix + distro + "-" + target_sys + "-" + float + "-" + VERSION + "-" + name
68 tar_file = os.path.join(ice_dir, 'ice', cross_name + '.tar.gz')
72 # tar file already exists
76 os.makedirs(os.path.join(ice_dir,'ice'))
78 # directory already exists, continue
82 #check if user has specified a specific icecc-create-env script
83 #if not use the OE provided one
84 cr_env_script = bb.data.expand('${ICECC_ENV_EXEC}', d)
85 if cr_env_script == "${ICECC_ENV_EXEC}":
86 cr_env_script = bb.data.expand('${STAGING_DIR}', d)+"/ice/icecc-create-env"
87 #call the modified create-env script
88 result=os.popen("%s %s %s %s %s %s" %(cr_env_script,
90 os.path.join(ice_dir, 'bin', "%s-gcc" % target_sys),
91 os.path.join(ice_dir, 'bin', "%s-g++" % target_sys),
92 os.path.join(ice_dir, 'bin', "%s-as" % target_sys),
93 os.path.join(ice_dir,"ice",cross_name) ) )
97 def create_native_env(bb,d):
98 import tarfile, socket, time
99 ice_dir = bb.data.expand('${CROSS_DIR}', d)
100 prefix = bb.data.expand('${HOST_PREFIX}' , d)
101 distro = bb.data.expand('${DISTRO}', d)
102 target_sys = bb.data.expand('${TARGET_SYS}', d)
103 target_prefix = bb.data.expand('${TARGET_PREFIX}', d)
104 float = bb.data.getVar('TARGET_FPU', d) or "hard"
105 name = socket.gethostname()
107 archive_name = "local-host-env" + "-" + name
108 tar_file = os.path.join(ice_dir, 'ice', archive_name + '.tar.gz')
112 # tar file already exists
116 #os.makedirs(os.path.join(ice_dir))
117 os.makedirs(os.path.join(ice_dir,'ice'))
119 # directory already exists, continue
122 #check if user has specified a specific icecc-create-env script
123 #if not use the OE provided one
124 cr_env_script = bb.data.expand('${ICECC_ENV_EXEC}', d)
125 if cr_env_script == "${ICECC_ENV_EXEC}":
126 cr_env_script = bb.data.expand('${STAGING_DIR}', d)+"/ice/icecc-create-env"
127 result=os.popen("%s %s %s %s %s %s" %(cr_env_script,
129 os.popen("%s gcc" % "which").read()[:-1],
130 os.popen("%s g++" % "which").read()[:-1],
131 os.popen("%s as" % "which").read()[:-1],
132 os.path.join(ice_dir,"ice",archive_name) ) )
136 def get_cross_kernel_cc(bb,d):
137 kernel_cc = bb.data.expand('${KERNEL_CC}', d)
138 kernel_cc = kernel_cc.replace('ccache', '').strip()
139 kernel_cc = kernel_cc.split(' ')[0]
140 kernel_cc = kernel_cc.strip()
144 def create_cross_kernel_env(bb,d):
145 import tarfile, socket, time
146 ice_dir = bb.data.expand('${CROSS_DIR}', d)
147 prefix = bb.data.expand('${HOST_PREFIX}' , d)
148 distro = bb.data.expand('${DISTRO}', d)
149 target_sys = bb.data.expand('${TARGET_SYS}', d)
150 target_prefix = bb.data.expand('${TARGET_PREFIX}', d)
151 float = bb.data.getVar('TARGET_FPU', d) or "hard"
152 name = socket.gethostname()
153 kernel_cc = get_cross_kernel_cc(bb, d)
155 # Stupid check to determine if we have built a libc and a cross
158 os.stat(os.path.join(ice_dir, 'bin', kernel_cc))
159 except: # no cross compiler built yet
162 VERSION = icc_determine_gcc_version( os.path.join(ice_dir,"bin",kernel_cc) )
163 cross_name = prefix + distro + "-kernel-" + target_sys + "-" + float + "-" + VERSION + "-" + name
164 tar_file = os.path.join(ice_dir, 'ice', cross_name + '.tar.gz')
168 # tar file already exists
172 os.makedirs(os.path.join(ice_dir,'ice'))
174 # directory already exists, continue
178 #check if user has specified a specific icecc-create-env script
179 #if not use the OE provided one
180 cr_env_script = bb.data.getVar('ICECC_ENV_EXEC', d) or bb.data.expand('${STAGING_DIR}', d)+"/ice/icecc-create-env"
181 result=os.popen("%s %s %s %s %s %s" %(cr_env_script,
183 os.path.join(ice_dir, 'bin', kernel_cc),
184 os.path.join(ice_dir, 'bin', "%s-g++" % target_sys),
185 os.path.join(ice_dir, 'bin', "%s-as" % target_sys),
186 os.path.join(ice_dir, "ice", cross_name) ) )
190 def create_env(bb,d):
192 #return create_cross_kernel_env(bb,d)
194 if bb.data.inherits_class("native", d):
195 return create_native_env(bb,d)
196 elif bb.data.inherits_class("kernel", d):
197 return create_cross_kernel_env(bb,d)
198 elif bb.data.inherits_class("cross", d):
199 return create_native_env(bb,d)
200 elif bb.data.inherits_class("sdk", d):
201 return create_native_env(bb,d)
203 return create_cross_env(bb,d)
206 def create_path(compilers, type, bb, d):
208 Create Symlinks for the icecc in the staging directory
210 staging = os.path.join(bb.data.expand('${STAGING_DIR}', d), "ice", type)
212 #check if the icecc path is set by the user
213 icecc = bb.data.getVar('ICECC_PATH', d) or os.popen("%s icecc" % "which").read()[:-1]
215 # Create the dir if necessary
221 for compiler in compilers:
222 gcc_path = os.path.join(staging, compiler)
226 os.symlink(icecc, gcc_path)
231 def use_icc_version(bb,d):
233 system_class_blacklist = [ "none" ]
235 for black in system_class_blacklist:
236 if bb.data.inherits_class(black, d):
239 user_class_blacklist = bb.data.getVar('ICECC_USER_CLASS_BL', d) or "none"
240 user_class_blacklist = user_class_blacklist.split()
242 for black in user_class_blacklist:
243 if bb.data.inherits_class(black, d):
250 package_tmp = bb.data.expand('${PN}', d)
252 #"system" package blacklist contains a list of packages that can not distribute compile tasks
253 #for one reason or the other
254 system_package_blacklist = [ "uclibc", "glibc", "gcc", "bind", "u-boot", "dhcp-forwarder", "enchant", "connman" ]
255 user_package_blacklist = (bb.data.getVar('ICECC_USER_PACKAGE_BL', d) or "").split()
256 package_blacklist = system_package_blacklist + user_package_blacklist
258 for black in package_blacklist:
259 if black in package_tmp:
260 bb.note(package_tmp, ' found in blacklist, disable icecc')
261 fallback_parallel = bb.data.getVar('ICECC_FALLBACK_PARALLEL', d) or ""
262 bb.data.setVar("PARALLEL_MAKE", fallback_parallel, d)
265 prefix = bb.data.expand('${HOST_PREFIX}', d)
267 if bb.data.inherits_class("cross", d):
268 return create_path( ["gcc", "g++"], "native", bb, d)
270 elif bb.data.inherits_class("native", d):
271 return create_path( ["gcc", "g++"], "native", bb, d)
273 elif bb.data.inherits_class("kernel", d):
274 return create_path( [get_cross_kernel_cc(bb,d), ], "cross-kernel", bb, d)
276 elif len(prefix) == 0:
277 return create_path( ["gcc", "g++"], "native", bb, d)
280 return create_path( [prefix+"gcc", prefix+"g++"], "cross", bb, d)
283 def icc_version(bb,d):
284 return create_env(bb,d)
287 def check_for_kernel(bb,d):
288 if bb.data.inherits_class("kernel", d):
294 ICE_PATH=${@icc_path(bb,d)}
295 if test x${ICE_PATH} != x; then
296 export PATH=${ICE_PATH}$PATH
297 export CCACHE_PATH=$PATH
298 #check if we are building a kernel and select gcc-cross-kernel
299 if [ "${@check_for_kernel(bb,d)}" = "yes" ]; then
300 export ICECC_CC="${@get_cross_kernel_cc(bb,d)}"
301 export ICECC_CXX="${HOST_PREFIX}g++"
303 export ICECC_CC="${HOST_PREFIX}gcc"
304 export ICECC_CXX="${HOST_PREFIX}g++"
307 if [ "${@use_icc_version(bb,d)}" = "yes" ]; then
308 export ICECC_VERSION="${@icc_version(bb,d)}"
310 export -n ICECC_VERSION
312 oenote "set the icecream environment variables: PATH=$PATH, CCACHE_PATH=$CCACHE_PATH, ICECC_CC=$ICECC_CC, ICECC_CXX=$ICECC_CXX, ICECC_VERSION=$ICECC_VERSION"
316 do_configure_prepend() {
320 do_compile_prepend() {
324 do_install_prepend() {