kexec-tools-klibc-static: don't use OE compiler flags. Use default
[openembedded.git] / recipes / kexec-tools / kexec-tools-klibc-static_1.101.bb
blob579af3658e73c5bbcaecdf3c07a55dccf8f46bad
1 # the binaries are statical linked against klibc
2 require kexec-tools.inc
4 PR = "r8"
5 DEPENDS = "klibc"
7 SRC_URI += "file://kexec-static.patch;patch=1 \
8 file://kexec-klibc.patch;patch=1 \
10 S = "${WORKDIR}/kexec-tools-${PV}"
12 EXTRA_OECONF = " --without-zlib"
14 # reset inherited OE flags to avoid e.g. ggdb3 and keep size small
15 export CFLAGS=""
16 export CPPFLAGS=""
17 export LDFLAGS=""
19 export CC=${TARGET_PREFIX}klcc
21 PACKAGES =+ "kexec-klibc-static kdump-klibc-static"
23 FILES_kexec-klibc-static = "${sbindir}/kexec"
24 FILES_kdump-klibc-static = "${sbindir}/kdump"