1 DESCRIPTION
= "TagLib is a library for reading and editing the meta-data of several popular audio formats"
2 SECTION
= "libs/multimedia"
3 HOMEPAGE
= "http://developer.kde.org/~wheeler/taglib.html"
7 SRC_URI
= "http://developer.kde.org/~wheeler/files/src/taglib-${PV}.tar.gz \
8 file://add_missing_exports_fix.diff \
9 file://gcc_visibility_feature.diff \
10 file://link_interface_libraries_fix.diff \
13 S
= "${WORKDIR}/taglib-${PV}"
15 inherit cmake pkgconfig binconfig
18 install
-d $
{STAGING_INCDIR
}/$
{PN
}
19 install
-m
0644 $
{D
}/$
{includedir
}/$
{PN
}/*.h $
{STAGING_INCDIR
}/$
{PN
}
20 install
-m
0644 $
{D
}/$
{includedir
}/$
{PN
}/*.tcc $
{STAGING_INCDIR
}/$
{PN
}
21 oe_libinstall
-C $
{PN
} -so libtag $
{STAGING_LIBDIR
}
24 LEAD_SONAME
= "libtag.so.1"
28 FILES_$
{PN
} = "${libdir}/libtag.so.*"
29 FILES_$
{PN
}-c
= "${libdir}/libtag_c.so.*"
31 SRC_URI
[md5sum
] = "7b557dde7425c6deb7bbedd65b4f2717"
32 SRC_URI
[sha256sum
] = "ba610716ec539d4858133e008d079728953820c583b200ff0936e36fc0550ec2"