fsogsmd: should now depend on msmcomm-specs rather than msmcommd-specs
[openembedded.git] / recipes / hal / ohm_git.bb
blob24d49f42d85886cc84be79ae60c015e5818889c3
1 DESCRIPTION = "Open Hardware Manager"
2 HOMEPAGE = "http://freedesktop.org/Software/ohm"
3 LICENSE = "LGPL"
5 DEPENDS = "gtk+ dbus-glib intltool-native hal"
6 RDEPENDS_${PN} += "udev hal-info"
7 SRC_URI = "git://anongit.freedesktop.org/git/ohm/;protocol=git \
8 file://fix_configure.patch"
10 SRCREV = "3cb3496846508929b9f2d05683ec93523de7947c"
11 PV = "0.1.2+${PR}+gitr${SRCREV}"
12 PE = "1"
13 PR = "r1"
15 S = "${WORKDIR}/git"
17 inherit autotools pkgconfig
19 EXTRA_OECONF = "--with-distro=debian \
20 --without-xauth \
21 --disable-gtk-doc \
22 --disable-docbook-docs"
24 do_configure_prepend() {
25 touch gtk-doc.make
28 OE_LT_RPATH_ALLOW=":${libdir}/libohm:"
29 OE_LT_RPATH_ALLOW[export]="1"
31 PACKAGES =+ "libohm ohm-plugin-x11"
33 FILES_${PN}-dev += "${libdir}/ohm/*.a ${libdir}/ohm/*.la"
35 FILES_${PN} = "${sysconfdir} \
36 ${bindir}/* \
37 ${sbindir}/* \
38 ${libdir}/ohm/*.so \
41 FILES_libohm = "${libdir}/libohm.so.*"
42 FILES_ohm-plugin-x11 = "${libdir}/ohm/libohm_x*.so \
43 ${libdir}/ohm/libohm_idle.so \
44 ${sysconfdir}/ohm/plugins.d/x* \
45 ${sysconfdir}/ohm/plugins.d/idle* \