fsogsmd: should now depend on msmcomm-specs rather than msmcommd-specs
[openembedded.git] / recipes / binutils / binutils_2.15.94.0.1.bb
blob50ae28862eb12787b2a1310a7d7cd415a3bb8986
1 DESCRIPTION = "A GNU collection of binary utilities"
2 HOMEPAGE = "http://www.gnu.org/software/binutils/"
3 SECTION = "devel"
4 LICENSE = "GPL"
5 INC_PR = "r5"
6 PR = "${INC_PR}.1"
8 inherit autotools gettext
10 PACKAGES = "${PN} ${PN}-dev ${PN}-doc ${PN}-symlinks"
12 FILES_${PN} = " \
13 ${bindir}/${TARGET_PREFIX}* \
14 ${libdir}/lib*-*.so \
15 ${prefix}/${TARGET_SYS}/bin/*"
17 FILES_${PN}-dev = " \
18 ${includedir} \
19 ${libdir}/*.a \
20 ${libdir}/*.la \
21 ${libdir}/libbfd.so \
22 ${libdir}/libopcodes.so"
24 FILES_${PN}-symlinks = " \
25 ${bindir}/addr2line \
26 ${bindir}/ar \
27 ${bindir}/as \
28 ${bindir}/c++filt \
29 ${bindir}/gprof \
30 ${bindir}/ld \
31 ${bindir}/nm \
32 ${bindir}/objcopy \
33 ${bindir}/objdump \
34 ${bindir}/ranlib \
35 ${bindir}/readelf \
36 ${bindir}/size \
37 ${bindir}/strings \
38 ${bindir}/strip"
40 SRC_URI = \
41 "${KERNELORG_MIRROR}/pub/linux/devel/binutils/binutils-${PV}.tar.bz2 \
42 file://ld_makefile.patch \
43 file://better_file_error.patch \
44 file://signed_char_fix.patch \
45 file://objdump_fix.patch \
46 file://binutils-100_cflags_for_build.patch \
47 file://binutils-2.15.91.0.1-uclibc-100-conf.patch \
48 file://binutils-2.15.90.0.3-uclibc-200-build_modules.patch \
49 file://binutils-2.15-allow-gcc-4.0.patch"
50 S = "${WORKDIR}/binutils-${PV}"
51 B = "${S}/build.${HOST_SYS}.${TARGET_SYS}"
53 EXTRA_OECONF = "--program-prefix=${TARGET_PREFIX} \
54 --enable-shared"
56 # This is necessary due to a bug in the binutils Makefiles
57 EXTRA_OEMAKE = "configure-build-libiberty all"
59 export AR = "${HOST_PREFIX}ar"
60 export AS = "${HOST_PREFIX}as"
61 export LD = "${HOST_PREFIX}ld"
62 export NM = "${HOST_PREFIX}nm"
63 export RANLIB = "${HOST_PREFIX}ranlib"
64 export OBJCOPY = "${HOST_PREFIX}objcopy"
65 export OBJDUMP = "${HOST_PREFIX}objdump"
67 export AR_FOR_TARGET = "${TARGET_PREFIX}ar"
68 export AS_FOR_TARGET = "${TARGET_PREFIX}as"
69 export LD_FOR_TARGET = "${TARGET_PREFIX}ld"
70 export NM_FOR_TARGET = "${TARGET_PREFIX}nm"
71 export RANLIB_FOR_TARGET = "${TARGET_PREFIX}ranlib"
73 export CC_FOR_HOST = "${CCACHE} ${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
74 export CXX_FOR_HOST = "${CCACHE} ${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
76 export CC_FOR_BUILD = "${BUILD_CC}"
77 export CPP_FOR_BUILD = "${BUILD_CPP}"
78 export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
80 export CC = "${CCACHE} ${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
82 do_configure () {
83 (cd ${S}; gnu-configize) || die "Failed to run gnu-configize"
84 oe_runconf
87 do_install () {
88 autotools_do_install
90 # We don't really need these, so we'll remove them...
91 rm -rf ${D}${libdir}/ldscripts
93 # Fix the /usr/${TARGET_SYS}/bin/* links
94 for l in ${D}${prefix}/${TARGET_SYS}/bin/*; do
95 rm -f $l
96 ln -sf `echo ${prefix}/${TARGET_SYS}/bin \
97 | tr -s / \
98 | sed -e 's,^/,,' -e 's,[^/]*,..,g'`${bindir}/${TARGET_PREFIX}`basename $l` $l
99 done
101 # Install the libiberty header
102 install -d ${D}${includedir}
103 install -m 644 ${S}/include/ansidecl.h ${D}${includedir}
104 install -m 644 ${S}/include/libiberty.h ${D}${includedir}
106 cd ${D}${bindir}
108 # Symlinks for ease of running these on the native target
109 for p in ${TARGET_SYS}-* ; do
110 ln -sf $p `echo $p | sed -e s,${TARGET_SYS}-,,`
111 done
114 SRC_URI[md5sum] = "4a4cde8e5d0c97249bf6933f095813fe"
115 SRC_URI[sha256sum] = "c4ad801a7ed5a4e3d5d943d73c82f0af75998c95b69184dc884460bf40e48ee9"