fsogsmd: should now depend on msmcomm-specs rather than msmcommd-specs
[openembedded.git] / recipes / angstrom / angstrom-uboot-scripts.bb
blobf5fab905e74af2387a69b7350fb2efaabeb664cc
1 DESCRIPTION = "Various uboot scripts"
2 LICENSE = "MIT"
4 PR = "r11"
6 DEPENDS = "u-boot-mkimage-native"
8 SRC_URI = "file://*.cmd"
10 do_configure() {
11 cp ${WORKDIR}/*.cmd ${S}
13 for i in *.cmd ; do
14 mv $i uboot-$i
15 done
18 do_compile() {
19 for i in *.cmd ; do
20 uboot-mkimage -A ${TARGET_ARCH} -O linux -T script -C none -a 0 -e 0 -n "Angstrom $i" -d $i $i.scr
21 done
24 do_install() {
25 install -d ${D}/boot/u-boot-scripts
26 for i in *.cmd *.scr ; do
27 install -m 0644 $i ${D}/boot/u-boot-scripts
28 done
31 FILES_${PN} += "/boot"
33 addtask deploy before do_package after do_install
35 do_deploy() {
36 install -d ${DEPLOY_DIR_IMAGE}
37 for i in *.scr ; do
38 cp $i ${DEPLOY_DIR_IMAGE}
39 package_stagefile_shell ${DEPLOY_DIR_IMAGE}/$i
40 done
43 PACKAGE_ARCH = "${MACHINE_ARCH}"