matrix-gui-common: make versioned recipes
[openembedded.git] / recipes / vectoroids / vectoroids_1.1.0.bb
blobe6debbaed20101b91204306028d38a1ad7b46dea
1 DESCRIPTION = "Clone of the classic arcade game Asteroids - SDL edition."
2 SECTION = "opie/games"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 PR = "r2"
7 APPIMAGE = "data/images/icon.png"
8 APPNAME = "vectoroids-${PV}"
10 SRC_URI = "ftp://ftp.billsgames.com/unix/x/vectoroids/src/vectoroids-${PV}.tar.gz"
12 inherit qmake sdl
14 EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${STAGING_INCDIR}/SDL CONFIG-=qt \
15 LIBS+=-lSDL \
16 LIBS+=-lSDL_mixer \
17 LIBS+=-lSDL_image \
18 LIBS+=-lpthread \
19 DEFINES+=DATA_PREFIX=\\"\"${datadir}/vectoroids/\\"\""
21 do_configure_prepend() {
22 qmake -project vectoroids.pro
25 do_install() {
26 install -d ${D}${bindir}
27 install -m 0755 ${APPNAME} ${D}${bindir}
28 install -d ${D}${datadir}/vectoroids/
29 cp -pPR data/* ${D}${datadir}/vectoroids/
32 SRC_URI[md5sum] = "c63ce56b09aa7da9a6e95d804e9ee314"
33 SRC_URI[sha256sum] = "8d14dd281767e994108abd77c8e67d5a17718d0ad1e34d37e026911d14697b2e"