matrix-gui-common: make versioned recipes
[openembedded.git] / recipes / ti / matrix-gui-e_svn.bb
blob5570d9258f7a4de920e44ef584e98af864982a5d
1 DESCRIPTION = "Matrix GUI for Qt Embedded"
2 HOMEPAGE = "https://gforge.ti.com/gf/project/matrix_gui/"
3 LICENSE = "BSD"
4 SECTION = "multimedia"
5 PRIORITY = "optional"
7 SRCREV = "136"
8 PV = "1.1"
9 PR = "r18+svnr${SRCPV}"
11 PLATFORM_dm365 = "dm365"
12 PLATFORM_da850-omapl138-evm = "omapl138"
13 PLATFORM_omap3evm = "omap3530"
14 PLATFORM_dm37x-evm = "dm3730"
15 PLATFORM_am37x-evm = "am3715"
16 PLATFORM_beagleboard = "am3715"
17 PLATFORM ?= "<UNDEFINED>"
19 SRC_URI = "svn://gforge.ti.com/svn/matrix_gui/;module=trunk;proto=https;user=anonymous;pswd='' "
21 S = "${WORKDIR}/trunk"
23 INITSCRIPT_NAME = "matrix-gui-e"
24 INITSCRIPT_PARAMS = "defaults 99"
25 #INITSCRIPT_PARAMS = "start 99 3 . stop 99 3 ."
27 CXXFLAGS_da850-omapl138-evm_append = " -DPlatform_omapl138 "
28 CXXFLAGS_dm365_append = " -DPlatform_dm365 "
29 PACKAGE_ARCH = ${MACHINE_ARCH}
31 inherit qt4e update-rc.d
33 do_install() {
34 install -d ${D}/${bindir}
35 install -m 0755 ${S}/matrix_gui ${D}/${bindir}/matrix_guiE
36 install -d ${D}${sysconfdir}/init.d/
37 install -c -m 0755 ${S}/${PLATFORM}/etc/init ${D}${sysconfdir}/init.d/matrix-gui-e
41 RRECOMMENDS_${PN} = "qt4-embedded-plugin-mousedriver-tslib qt4-embedded-fonts"
42 RDEPENDS_${PN} += "matrix-gui-common"