matrix-gui-common: make versioned recipes
[openembedded.git] / recipes / device-mapper / device-mapper_1.01.04.bb
blobe761d4813fa1d457149cfcb709885414c877c4d7
1 SECTION = "libs"
2 DESCRIPTION = "The Device-mapper is a new component of the linux kernel \
3 that supports logical volume management. It is required by LVM2 and EVMS. \
4 The original LVM (included in stock 2.4 kernels) does not use it."
5 LICENSE = "GPL"
6 PR = "r2"
8 S = "${WORKDIR}/${PN}.${PV}"
10 SRC_URI = "ftp://sources.redhat.com/pub/dm/device-mapper.${PV}.tgz \
11 file://devmap-mknod-busybox.patch"
13 inherit autotools update-rc.d
15 INITSCRIPT_NAME = "devmap_mknod.sh"
16 INITSCRIPT_PARAMS = "defaults"
18 do_stage () {
19 install -m 0644 lib/libdevmapper.h ${STAGING_INCDIR} || die "failed to install libdevmapper.h"
20 oe_libinstall -a -so -C lib/ioctl libdevmapper ${STAGING_LIBDIR}
23 do_install() {
24 autotools_do_install
25 oe_runmake install_static_lib
26 install -D -m 755 ${S}/scripts/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
29 SRC_URI[md5sum] = "42dd0610e24d4b4f2409a32a04e6e37f"
30 SRC_URI[sha256sum] = "49c8303f58abf3a0efbbd42decdc5968688df32c154cffb20a1c3c1ae8b92048"