ti-c6accel_1.00.00.04: add new recipe
[openembedded.git] / recipes / gdal / gdal_1.5.2.bb
blob4ad15ea4c5a2b9331ed8954695f21358e489b1a1
1 DESCRIPTION = "GDAL is a translator library for raster geospatial data formats"
2 HOMEPAGE = "http://www.gdal.org/"
3 LICENSE = "MIT"
4 DEPENDS = "proj-4 sqlite3 zlib jpeg libpng tiff giflib curl jasper expat"
5 PR = "r3"
7 SRC_URI = "http://www.gdal.org/dl/${P}.tar.gz \
8 file://gdal_config.patch \
11 ARM_INSTRUCTION_SET = "arm"
13 inherit autotools binconfig
15 EXTRA_OECONF = "--without-perl \
16 --without-python \
17 --without-php \
18 --without-ruby \
19 --with-libz=${STAGING_DIR_TARGET} \
20 --with-png=${STAGING_DIR_TARGET} \
21 --with-jpeg=${STAGING_DIR_TARGET} \
22 --with-libtiff=${STAGING_DIR_TARGET} \
23 --with-gif=${STAGING_DIR_TARGET} \
24 --with-jasper=${STAGING_DIR_TARGET} \
25 --with-expat=${STAGING_DIR_TARGET} \
26 --with-expat-inc=${STAGING_INCDIR} \
27 --with-expat-lib=${STAGING_LIBDIR} \
30 # GDAL clutter /usr/share with files instead of using a subdir :(
31 FILES_${PN}-dev += "${datadir}"
33 do_compile() {
34 oe_runmake default
37 SRC_URI[md5sum] = "1939de5fe43d12884d85fa5d7797e3c2"
38 SRC_URI[sha256sum] = "243dabf3c45530cac8be092f9a1d838a46b46a92d4138870423006ffd6ae4001"