freesmartphone: bump cornucopia, msmcomm, libfso-glib, fso-specs, libgisi SRCREV
[openembedded.git] / recipes / xserver-common / xserver-common_1.34.bb
blob02549653514d9148dab062caf6f4b3795d715f9b
1 DESCRIPTION = "Common X11 scripts and support files"
2 LICENSE = "GPL"
3 SECTION = "x11"
4 RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo"
5 PR = "r0"
7 PACKAGE_ARCH = "all"
8 DEFAULT_PREFERENCE = "-1"
10 RCONFLICTS_${PN} = "xserver-kdrive-common"
11 RREPLACES_${PN} = "xserver-kdrive-common"
13 # we are using a gpe-style Makefile
14 inherit gpe
16 SRC_URI[md5sum] = "82f2f84cd96610e8f7b92c700cd31c14"
17 SRC_URI[sha256sum] = "cd04c33418f776b1e13fcc7af3d6bd0c7cccd03fbabd7dbcd97f88166cc34210"
19 SRC_URI_append = " \
20 file://setDPI.sh \
21 file://89xdgautostart.sh"
23 SRC_URI_append_angstrom = " file://xtscal-fix.patch "
24 RDEPENDS_${PN}_append_angstrom = " tslib-calibrate "
25 RDEPENDS_${PN}_append_shr = " xinput-calibrator "
27 SRC_URI_append_shr = " file://89xTs_Calibrate.xinput_calibrator.patch \
28 file://90xXWindowManager.patch \
29 file://Xserver.add.nocursor.for.gta.patch \
30 file://Xserver.add.xserver-system.patch \
31 file://Xserver.add.dpi.for.gta.patch \
32 file://Xserver.n900.patch"
34 do_install_append() {
35 install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
36 install -m 0755 "${WORKDIR}/89xdgautostart.sh" "${D}/etc/X11/Xsession.d/89xdgautostart"
37 sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/xserver-common