freesmartphone: bump cornucopia, msmcomm, libfso-glib, fso-specs, libgisi SRCREV
[openembedded.git] / recipes / mozilla / firefox_3.6.8.bb
blob04dde089892dd5b7035afd6f0af66edc36069fe4
1 DEPENDS += "cairo sqlite3 libnotify"
2 PR = "r3"
4 # The .pc files below have "3.6" hardcoded, fix that before using them in a newer FF version!
5 SRC_URI = "ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}.source.tar.bz2;name=archive \
6 file://jsautocfg.h \
7 file://security-cross.patch \
8 file://Bug339782.additional.fix.diff \
9 file://Bug385583.nspr.jmp_buf.eabi.diff \
10 file://Bug405992.atomic.nspr.diff \
11 file://jemalloc-tls.patch \
12 file://0001-Remove-Werror-from-build.patch \
13 file://0002-Fix-security-cross-compile-cpu-detection-error.patch \
14 file://plugins-dir.patch \
15 file://Add-nanojit-support-for-ARMv4T.patch \
16 file://firefox-plugin.pc \
17 file://firefox-xpcom.pc \
18 file://nspr.pc \
19 file://xulrunner-chromium-mips.patch \
20 file://xulrunner-1.9.2.8-mips-bus-error.patch \
21 file://Fix-xptinvoke-and-xptstubs-on-mips-o32-big-endian.patch \
22 file://Increase-stability-and-performance-on-mips.patch \
25 SRC_URI_append_mipsel = " file://mips-disable-TLS.patch "
27 SRC_URI[archive.md5sum] = "0ee5f14fd8be07513d16131027ebcb61"
28 SRC_URI[archive.sha256sum] = "fc609cc6a0ddaa2a9ebd8511ec39ae4a404e1107a12e07b233e2afca51d9a10e"
30 S = "${WORKDIR}/mozilla-1.9.2"
32 inherit mozilla
33 require firefox.inc
35 EXTRA_OECONF += " --enable-official-branding --disable-crashreporter"
37 FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
39 do_compile_prepend() {
40 cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
41 sed -i "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" security/coreconf/Linux.mk