freesmartphone: bump cornucopia, msmcomm, libfso-glib, fso-specs, libgisi SRCREV
[openembedded.git] / recipes / mc / mc_4.7.5.bb
blob16b5816fab8cb4a7036d288b2e5603030bc4b1f7
1 require mc.inc
2 PR = "${INC_PR}.0"
3 HOMEPAGE = "http://www.midnight-commander.org/"
5 SRC_URI = "http://www.midnight-commander.org/downloads/${P}.tar.gz \
7 SRC_URI[md5sum] = "5bb6a0130df3f3df3092a7b1b3e14fc7"
8 SRC_URI[sha256sum] = "668d8d66ce092ad17caaa82b2a281b9486b2b2137e662b7e9ff20f77e0782401"
10 EXTRA_OECONF = "--without-x --without-samba \
11 --without-nfs --without-gpm-mouse --enable-charset \
12 --with-screen=ncurses \
13 ac_cv_path_PERL=${bindir}/perl \
14 ac_cv_path_ZIP=${bindir}/zip \
15 ac_cv_path_UNZIP=${bindir}/unzip \
18 do_unpack_append() {
19 bb.build.exec_func('do_utf8_conversion', d)
21 do_utf8_conversion() {
22 cd ${S}/doc/hints
23 iconv -f iso8859-1 -t utf-8 -o mc.hint.tmp mc.hint && mv mc.hint.tmp mc.hint
24 iconv -f iso8859-1 -t utf-8 -o mc.hint.es.tmp mc.hint.es && mv mc.hint.es.tmp mc.hint.es
25 iconv -f iso8859-1 -t utf-8 -o mc.hint.it.tmp mc.hint.it && mv mc.hint.it.tmp mc.hint.it
26 iconv -f iso8859-1 -t utf-8 -o mc.hint.nl.tmp mc.hint.nl && mv mc.hint.nl.tmp mc.hint.nl
27 iconv -f iso8859-2 -t utf-8 -o mc.hint.cs.tmp mc.hint.cs && mv mc.hint.cs.tmp mc.hint.cs
28 iconv -f iso8859-2 -t utf-8 -o mc.hint.hu.tmp mc.hint.hu && mv mc.hint.hu.tmp mc.hint.hu
29 iconv -f iso8859-2 -t utf-8 -o mc.hint.pl.tmp mc.hint.pl && mv mc.hint.pl.tmp mc.hint.pl
30 iconv -f iso8859-5 -t utf-8 -o mc.hint.sr.tmp mc.hint.sr && mv mc.hint.sr.tmp mc.hint.sr
31 iconv -f koi8-r -t utf8 -o mc.hint.ru.tmp mc.hint.ru && mv mc.hint.ru.tmp mc.hint.ru
32 iconv -f koi8-u -t utf8 -o mc.hint.uk.tmp mc.hint.uk && mv mc.hint.uk.tmp mc.hint.uk
33 iconv -f big5 -t utf8 -o mc.hint.zh.tmp mc.hint.zh && mv mc.hint.zh.tmp mc.hint.zh
34 iconv -f iso8859-5 -t utf-8 -o mc.menu.sr.tmp mc.menu.sr && mv mc.menu.sr.tmp mc.menu.sr
35 # convert docs to utf-8
36 cd ${S}/doc/man/es
37 iconv -f iso8859-1 -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
38 iconv -f iso8859-1 -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
39 cd ${S}/doc/man/hu
40 iconv -f iso8859-2 -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
41 iconv -f iso8859-2 -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
42 cd ${S}/doc/man/it
43 iconv -f iso8859-1 -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
44 iconv -f iso8859-1 -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
45 cd ${S}/doc/man/pl
46 iconv -f iso8859-2 -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
47 iconv -f iso8859-2 -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
48 cd ${S}/doc/man/ru
49 iconv -f koi8-r -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
50 iconv -f koi8-r -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
51 cd ${S}/doc/man/sr
52 iconv -f iso8859-5 -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
53 iconv -f iso8859-5 -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
54 iconv -f iso8859-5 -t utf-8 -o mcserv.8.in.tmp mcserv.8.in && mv mcserv.8.in.tmp mcserv.8.in
55 cd ${S}
58 do_configure_prepend() {
60 AUTOFOO="config.guess config.sub depcomp install-sh missing mkinstalldirs"
62 for i in ${AUTOFOO}; do
63 rm config/${i}
64 done