cornucopia: bump SRCREV
[openembedded.git] / recipes / uclibc / uclibc_0.9.28.bb
blob7da53f9442f6474cd9ebee319f054200cb3ef03e
1 require uclibc-old.inc
2 PR = "${INC_PR}.0"
4 # This is the correct KERNEL_SOURCE location, if the uClibc
5 # fix_includes.sh script is run (see nokernelheader.patch below)
6 # this must be correct.
7 KERNEL_SOURCE = "${STAGING_DIR_HOST}/${exec_prefix}"
8 PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"
10 S = "${WORKDIR}/uClibc-${PV}"
12 #*** PATCHES ***
14 # The nokernelheadercheck patch removes the check on the include
15 # files in ${KERNEL_SOURCE}, however this check seems to be
16 # functioning correct now so the patch is not included. It may
17 # be necessary to add this for architectures which do not initially
18 # have a 'good' set of kernel header files in the cross directory.
19 #SRC_URI += "file://nokernelheadercheck.patch"
21 # Thumb support
23 # Thumb interworking support
24 THUMBSTUFF = " \
25 file://thumb-defined-arm-or-thumb.patch \
26 file://thumb-mov-pc-bx.patch \
27 file://thumb-swi-r7.patch \
28 file://thumb-sysnum-h.patch \
29 file://thumb-asm-swi.patch \
30 file://thumb-call-via-rx.patch \
31 file://dl-startup.h.patch \
32 file://dl-string.h.patch \
33 file://dl-sysdep.h.patch \
34 file://uclibc-libgcc-eh.patch \
37 SRC_URI_append_arm = " ${THUMBSTUFF} "
40 # This is a core change and is controversial, maybe even wrong
41 # on some architectures
42 THUMB_INTERWORK_RESOLVE_PATCH = ""
43 THUMB_INTERWORK_RESOLVE_PATCH_thumb-interwork = " file://thumb-resolve.patch"
44 SRC_URI += " ${THUMB_INTERWORK_RESOLVE_PATCH}"
47 DEFAULT_PREFERENCE_avr32 = "6000"
48 SRC_URI_append_avr32 = " \
49 file://uclibc-makefile.patch \
50 file://remove-bogus-version-hack-and-just-use-asm-generic-if-it-exists.patch \
51 file://let-optimized-stringops-override-default-ones.patch \
52 file://fix-getrusage-argument-type.patch \
53 file://fix-__libc_fcntl64-varargs-prototype.patch \
54 file://fix-broken-__libc_open-declaration.patch \
55 file://avr32-arch-2.patch \
56 file://avr32-linkrelax-option.patch \
57 file://avr32-string-ops.patch \
58 file://no-create_module-on-avr32.patch \
59 file://ldso-always-inline-_dl_memcpy.patch \
60 file://ldso-define-MAP_FAILED.patch \
61 file://ldso-always-inline-syscalls.patch \
62 file://ldso-avr32-2.patch \
63 file://ldso-avr32-needs-CONSTANT_STRING_GOT_FIXUP.patch \
64 file://ldso-avr32-startup-hack.patch \
65 file://ldd-avr32-support.patch \
66 file://libpthread-avr32.patch \
67 file://sync-fcntl-h-with-linux-kernel.patch \
71 #file://uClibc-0.9.28-avr32-20060621.patch \
72 #file://uClibc-0.9.28-avr32-20061019.patch \
73 #file://uclibc-avr32-no-msoft-float.patch \
75 SRC_URI[uClibc-0.9.28.md5sum] = "1ada58d919a82561061e4741fb6abd29"
76 SRC_URI[uClibc-0.9.28.sha256sum] = "c8bc5383eafaa299e9874ae50acc6549f8b54bc29ed64a9a3387b3e4cd7f4bcb"