cornucopia: bump SRCREV
[openembedded.git] / recipes / uclibc / uclibc-initial_0.9.30.3.bb
bloba9fa1460235bbbc8d3747b9cb52bca3c35758a21
1 SECTION = "base"
2 require uclibc_${PV}.bb
4 DEPENDS = "linux-libc-headers ncurses-native virtual/${TARGET_PREFIX}gcc-initial"
5 PROVIDES = "virtual/${TARGET_PREFIX}libc-initial"
6 PACKAGES = ""
8 do_install() {
9 # Install initial headers into the cross dir
10 make V=1 CC="${CC}" PREFIX=${D} DEVEL_PREFIX=${prefix}/ RUNTIME_PREFIX=/ \
11 install_headers
12 #ln -sf include ${CROSS_DIR}/${TARGET_SYS}/sys-include
14 # This conflicts with the c++ version of this header
15 rm -f ${D}${includedir}/bits/atomicity.h
16 install -d ${D}${libdir}/
17 install -m 644 lib/crt[1in].o ${D}${libdir}/
18 install -m 644 lib/libc.so ${D}${libdir}/
21 do_compile () {
22 make V=1 CC="${CC}" PREFIX=${D} DEVEL_PREFIX=${prefix}/ RUNTIME_PREFIX=/ \
23 lib/crt1.o lib/crti.o lib/crtn.o
24 ${CC} -nostdlib -nostartfiles -shared -x c /dev/null \
25 -o lib/libc.so