cornucopia: bump SRCREV
[openembedded.git] / recipes / tasks / task-cli-tools.bb
blob7d71e9a25bafc539c820256120abf98efc259e35
1 DESCRIPTION = "A set of useful command line tools"
2 DESCRIPTION_${PN}-debug = "A set of command line tools useful for debugging"
3 SECTION = "console"
4 LICENSE = "MIT"
5 PV = "1.0"
6 PR = "r18"
8 inherit task
10 PACKAGES += "${PN}-debug"
12 def get_ltrace(bb, d):
13 if bb.data.getVar('TARGET_ARCH', d, 1) in [ 'sh4', 'sh3' ] :
14 return ""
15 return "ltrace"
17 RDEPENDS_${PN} = "\
18 dbus-daemon-proxy \
19 dosfstools \
20 htop \
21 iptables \
22 lsof \
23 mbuffer \
24 mdbus2 \
25 mtd-utils \
26 mterm2 \
27 nano \
28 nfs-utils-client \
29 nmon \
30 powertop \
31 screen \
32 socat \
33 sysstat \
36 RDEPENDS_${PN}-debug = "\
37 evtest \
38 devmem2 \
39 i2c-tools \
40 gdb \
41 ${@get_ltrace(bb, d)} \
42 mkdump \
43 mioctl \
44 procps \
45 pxaregs \
46 s3c24xx-gpio \
47 s3c64xx-gpio \
48 serial-forward \
49 strace \
50 tcpdump \