1 DESCRIPTION
= "A multi protocol instant messager library, Qt/Embedded based Palmtop Environments Edition"
2 SECTION
= "opie/applications"
3 DEPENDS
= "glib-2.0 gnutls"
4 RDEPENDS_$
{PN
} = "libgaim-plugins"
6 HOMEPAGE
= "http://gaim.sourceforge.net/"
9 SRC_URI
= "${SOURCEFORGE_MIRROR}/gaim/gaim-${PV}.tar.bz2 \
10 file://dont-look-for-gtk.patch \
11 file://libgaim.patch "
13 S
= "${WORKDIR}/gaim-${PV}"
17 EXTRA_OE_CONF
= "--disable-audio --disable-gtkspell --disable-perl \
18 --disable-screensaver --disable-sm --disable-glibtest \
19 --disable-gtktest --disable-startup-notification \
20 --disable-gevolution --disable-aotest --disable-audiofiletest \
21 --disable-x --without-x --without-gtk --disable-gtk \
24 CFLAGS_append
= " -I${STAGING_INCDIR}/glib-2.0 -I${STAGING_LIBDIR}/glib-2.0/include"
27 oe_libinstall
-so
-C src libgaim $
{QTDIR
}/lib
30 GAIM_DIR
=$
{STAGING_INCDIR
}/gaim
33 for header in account.h accountopt.h away.h blist.h buddyicon.h cmds.h config.h connection.h conversation.h core.h debug.h eventloop.h ft.h gaim.h imgstore.h
log.h md5.h network.h notify.h plugin.h pluginpref.h pounce.h prefix.h prefs.h privacy.h proxy.h prpl.h request.h roomlist.h server.h sha.h signals.h sound.h sslconn.h status.h stringref.h util.h value.h version.h xmlnode.h
35 if [ -e $
{S
}/src
/$header
]; then
36 install
-m
0644 $
{S
}/src
/$header $GAIM_DIR
38 if [ -e $
{S
}/$header
]; then
39 install
-m
0644 $
{S
}/$header $GAIM_DIR
44 PACKAGES_DYNAMIC
= "libgaim-protocol-*"
46 #FIXME
: use do_packages
to create individual packages
for each of the plugins
47 python populate_packages_prepend
() {
48 plugindir
= bb.
data.expand
('$
{libdir
}/gaim'
, d
)
49 do_split_packages
(d
, plugindir
, '^lib
(.
*)\.so$'
, 'libgaim
-protocol
-%s'
, 'GAIM plugin
for %s protocol'
, extra_depends
=''
)
52 PACKAGES
+= "libgaim-plugins"
53 FILES_libgaim
-plugins
= "${libdir}/gaim/autorecon.so ${libdir}/gaim/s*.so"
56 SRC_URI
[md5sum
] = "9205321ac11fad271c90f2f0d7c5e7ce"
57 SRC_URI
[sha256sum
] = "58e3b0340cfc9e54e46f8d8835e5a02e31201c9ed8820bbb4cea36c59b9682aa"