cornucopia: bump SRCREV
[openembedded.git] / recipes / qfish / qfish2_1.1.0.bb
blobfe16a9bb1227d99b57c512c0a18d75a3935ad609
1 DESCRIPTION = "A Game with fishes, Qt/Embedded based Palmtop Environments Edition"
2 SECTION = "opie/games"
3 LICENSE = "GPL"
4 PRIORITY = "optional"
5 PR = "r2"
7 SRC_URI = "http://taiga0818.hp.infoseek.co.jp/rpms/qfish2-${PV}.tar.gz"
8 S = "${WORKDIR}/qfish"
10 inherit palmtop
12 MACHTYPE = "sl300"
13 MACHTYPE_c7x0 = "sl700"
14 MACHTYPE_tosa = "sl700"
16 do_configure_append() {
17 ln -v -f -s config/config-${MACHTYPE}.h config.h
18 ln -v -f -s config/config.mk-${MACHTYPE} config.mk
19 if [ "${MACHTYPE}" = "sl300" ]
20 then
21 ln -vfs bigFishSize.h areaSize.h
22 else
23 ln -vfs smallFishSize.h areaSize.h
25 ln -v -f -s HiScoreRegConfig-${MACHTYPE}.h HiScoreRegConfig.h
28 do_compile_prepend() {
29 cd images && oe_runmake && cd ${S}
32 do_install() {
33 install -d ${D}${palmtopdir}/apps/Games
34 install -m 0644 desktop/qfish-${MACHTYPE}.desktop ${D}${palmtopdir}/apps/Games/qfish2.desktop
35 install -d ${D}${palmtopdir}/bin
36 install -m 0755 qfish ${D}${palmtopdir}/bin/qfish2
37 install -d ${D}${palmtopdir}/pics
38 install -m 0644 desktop/qfish2.png ${D}${palmtopdir}/pics/
39 install -d ${D}${palmtopdir}/sounds/qfish2
40 install -m 0644 sounds/*.wav ${D}${palmtopdir}/sounds/qfish2/
41 install -d ${D}${palmtopdir}/help/html/
42 install -m 0644 desktop/qfish.html ${D}${palmtopdir}/help/html/qfish2.html
45 SRC_URI[md5sum] = "2a8219bcb375fac66cea66394c3c36fa"
46 SRC_URI[sha256sum] = "1e097fdccda0fc914c8229aab7d83964c5944cc95eb053fd69e357dca69461b9"