cornucopia: bump SRCREV
[openembedded.git] / recipes / linux / linux-efikamx_2.6.31.bb
blob0484a5b172cac0e7bf6f3a58b261021f3920e015
1 require linux.inc
3 DESCRIPTION = "Linux kernel for EfikaMX platform"
4 KERNEL_IMAGETYPE = "uImage"
6 COMPATIBLE_MACHINE = "efikamx"
7 DEFAULT_PREFERENCE = "1"
8 python do_unpack () {
9 bb.build.exec_func('efikamx_kernel_do_unpack', d)
12 efikamx_kernel_do_unpack () {
13 mkdir -p ${S}
14 tar xf ${DL_DIR}/${PN}-${PV}.tar.lzma --strip-components=1 -C ${S}
15 tar xf ${DL_DIR}/patch-${PV}.tar.lzma -C ${S}
16 (cd ${S}/patches; ln -s ${FILESPATHBASE}/${PN}-${PV}/remove-localversion.patch .)
19 python do_patch () {
20 bb.build.exec_func('efikamx_kernel_do_patch', d)
23 efikamx_kernel_do_patch (){
24 ( cd ${S}/patches; ls *.patch >series;cp *.config ${S}/../defconfig)
25 ( cd ${S}; quilt push -a)
29 SRC_URI += "http://sources.openembedded.org/${P}.tar.lzma;name=kernel \
30 http://sources.openembedded.org/patch-${PV}.tar.lzma;name=patch \
31 file://remove-localversion.patch;apply=no \
34 SRC_URI[kernel.md5sum] = "c70ce0549cf85de79d5b28db7b552868"
35 SRC_URI[kernel.sha256sum] = "658395072352cd38477d80c105f00d824c73bf437f0843579d1e0bf41066617f"
36 SRC_URI[patch.md5sum] = "6c04416bce74dd413f3e82cd17378419"
37 SRC_URI[patch.sha256sum] = "5c15cffa02089d286fc07ba734b1f33a81d1f7ceaf70e596bd8b82ddd5e73ec2"