cornucopia: bump SRCREV
[openembedded.git] / recipes / fltk / efltk_2.0.7.bb
blob68329ab92c972cfd995822edfd96a77ea2519bae
1 DESCRIPTION = "EFLTK is a cross-platform C++ GUI toolkit"
2 HOMEPAGE = "http://equinox-project.org/page/documentation"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 LICENSE = "LGPL"
6 DEPENDS = "zlib jpeg libpng libxext libxft"
7 PR = "r0"
9 SRC_URI = "${SOURCEFORGE_MIRROR}/ede/efltk-${PV}.tar.gz \
10 file://fix.void.cast.patch"
11 S = "${WORKDIR}/efltk"
13 inherit autotools binconfig
15 EXTRA_OECONF = "\
16 --enable-shared \
17 --enable-xdbe \
18 --enable-xft \
19 --enable-gl \
20 --disable-mysql \
21 --disable-unixODBC \
22 --x-includes=${STAGING_INCDIR}/freetype2 \
23 --x-libraries=${STAGING_LIBDIR} \
26 # yes, this is nasty, but configure is so broken there is no other way
27 do_configure() {
28 gnu-configize
29 oe_runconf
30 mv -f config.h save
31 autotools_do_configure
32 mv -f save config.h
35 # more nasties
36 do_configure_append() {
37 sed -i s,/usr/include,${STAGING_INCDIR}, makeinclude
38 sed -i s,/usr/include/freetype2,, makeinclude
39 sed -i s,/usr/bin/strip,echo, makeinclude
40 sed -i s,CONFIGDIR,'"${datadir}/ede/"', src/core/Fl_Config.cpp
43 do_install () {
44 install -d ${D}${libdir}
45 oe_runmake install prefix="${D}${prefix}" \
46 bindir="${D}${bindir}" \
47 libdir="${D}${libdir}" \
48 includedir="${D}${includedir}" \
49 datadir="${STAGING_DATADIR}"
52 python populate_packages_prepend () {
53 if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
54 bb.data.setVar('PKG_${PN}', 'libefltk${PV}', d)
57 LEAD_SONAME = "libefltk.so"
59 FILES_${PN} += "${libdir}/fltk/*.theme"
60 FILES_${PN}-dbg += "${libdir}/fltk/.debug"
62 SRC_URI[md5sum] = "f0300fd2fec47d4b05823297032ddb9f"
63 SRC_URI[sha256sum] = "9636876e3c52f0dde5d6ac097568cad9fe8ea7088e28e27a3aad19b100d4e645"