cornucopia: bump SRCREV
[openembedded.git] / recipes / bzip2 / bzip2_1.0.6.bb
blob0d6d03052745375162223bbf87ab2a2b2ef4f92b
1 DESCRIPTION = "Very high-quality data compression program"
2 SECTION = "console/utils"
3 PR = "r0"
5 LICENSE = "bzip2"
6 SRC_URI = "http://www.bzip.org/${PV}/bzip2-${PV}.tar.gz \
7 file://bzip2-1.0.5-autoconfiscated.patch"
8 SRC_URI[md5sum] = "00b516f4704d4a7cb50a1d97e6e8e15b"
9 SRC_URI[sha256sum] = "a2848f34fcd5d6cf47def00461fcb528a0484d8edef8208d6d2e2909dc61d9cd"
11 inherit autotools pkgconfig
13 do_configure_prepend () {
14 if test -f LICENSE ; then sh ./autogen.sh ; fi
17 do_install_append () {
18 mv ${D}${bindir}/bunzip2 ${D}${bindir}/bunzip2.${PN}
19 mv ${D}${bindir}/bzcat ${D}${bindir}/bzcat.${PN}
20 ln -sf libbz2.so.${PV} ${D}${libdir}/libbz2.so.1.0
23 PACKAGES =+ "libbz2"
24 FILES_libbz2 = "${libdir}/libbz2.so.*"
26 pkg_postinst_${PN} () {
27 update-alternatives --install ${bindir}/bunzip2 bunzip2 bunzip2.${PN} 100
28 update-alternatives --install ${bindir}/bzcat bzcat bzcat.${PN} 100
31 pkg_prerm_${PN} () {
32 update-alternatives --remove bunzip2 bunzip2.${PN}
33 update-alternatives --remove bzcat bzcat.${PN}