cornucopia: bump SRCREV
[openembedded.git] / recipes / appweb / appweb_1.2.0.bb
blobd0acb9d83db760dd42ba4bef68b65729494ca2b9
1 DESCRIPTION = "AppWeb is an embedded HTTP Web server that has been designed with security in mind."
2 SECTION = "console/network"
3 LICENSE = "GPL"
4 SRC_URI = "http://www.mbedthis.com/software/appWeb-src-1.2.0-1.tar.gz \
5 file://makerules.patch \
6 file://nonrootinstall.patch"
7 S = "${WORKDIR}/appWeb-1.2.0"
9 APPWEB_HOST = "${@get_appweb_host(d, bb)}"
10 APPWEB_BUILD = "${BUILD_SYS}"
12 require appweb.inc
14 # --buildNumber=NUMBER Set the build number part of the version (1.0.0.X).
15 # --name=NAME Set the full product name (BLD_NAME define).
16 # --port=PORT Set the default HTTP port to use for the product.
17 # --product=NAME Set the one word (no spaces) name of the product.
18 # --setLibVersion=X.X.X Set the shared library version number.
19 # --setVersion=X.X.X Set the product version number.
20 # --sslPort=PORT Set the default SSL port to use for the product.
21 # --type=BUILD Set the build type (DEBUG|RELEASE).
23 # --enable-access-log Enable logging of requests to the AppWeb access log.
24 # --enable-assert Build with assert checking.
25 # --enable-config Build with the ability to parse Apache-style config
26 # --enable-cookie Build with cookie handling support.
27 # --enable-digest-auth Build with digest authentication support.
28 # --enable-fast-malloc Build with the Mbedthis fast malloc.
29 # --enable-if-modified Build with HTTP If-Modified checking.
30 # --enable-keep-alive Build with HTTP Keep-Alive support.
31 # --enable-log Build with the AppWeb trace log facility.
32 # --enable-modules Build with the dynamically loaded modules capability.
33 # --enable-multi-thread Build AppWeb multi-threaded.
34 # --disable-multi-thread Build AppWeb single threaded.
35 # --enable-rom-fs Build with the ability to load web pages from ROM.
36 # --enable-run-as-service Build with the ability to run as a service/daemon.
37 # --disable-run-as-service Do not include the ability to run as a service.
38 # --enable-safe-strings Enforce safe string handling.
39 # --enable-session Build with HTTP session support.
40 # --enable-shared Build an appWeb shared library and program. [default]
41 # --enable-shared-libc Link with the shared versions of libc.
42 # --disable-shared-libc Link with the static versions of libc.
43 # --enable-squeeze Build in squeeze mode for minimal memory footprint.
44 # --disable-squeeze Build for speed.
45 # --enable-static Build a static appWeb library and program. [default]
46 # --disable-static Do not build a static appWeb library and program.
48 # --with-admin Include the admin handler.
49 # --with-auth Include the authorization handler.
50 # --with-c_api Include the C API.
51 # --with-cgi Include the CGI handler.
52 # --with-gacompat Include GoAhead WebServer API compatibility.
53 # --with-copy Build support for the copy handler.
54 # --with-egi Include the EGI handler.
55 # --with-esp Include the ESP handler.
56 # --with-ssl Build support for the SSL protocol.
57 # --with-upload Build with the file upload handler
58 # --with-xdb Build with XDB
59 # Supported PACKAGE names: openssl, php4, php5
60 # --with-PACKAGE=[builtin|, module]
61 # Include support for the PACKAGE. Link into appWeb
62 # statically and/or build as a module
63 # --with-PACKAGE-dir=DIR Set the source directory of the package
64 # --with-PACKAGE-libs=libs Set a list of libraries to use when linking with
65 # the PACKAGE
66 # --without-PACKAGE Do not include support for the PACKAGE
67 EXTRA_OECONF = "--prefix=${prefix} \
68 --docDir=${docdir}/${P} \
69 --incDir=${includedir} \
70 --libDir=${libdir} \
71 --sbinDir=${sbindir} \
72 --webDir=${localstatedir}/www \
73 --build=${APPWEB_BUILD} \
74 --host=${APPWEB_HOST} \
75 --enable-keep-alive \
76 --enable-multi-thread \
77 --with-cgi=builtin \
78 --enable-cookie \
79 --enable-config \
80 --enable-digest-auth \
81 --without-ssl"
83 export IFLAGS = "${CPPFLAGS}"
84 export CC_FOR_BUILD = "${BUILD_CC}"
85 export LD_FOR_BUILD = "${BUILD_LD}"
87 LD_LIBRARY_PATH_prepend = "${S}/lib:"
88 LD_LIBRARY_PATH[export] = "1"
89 do_configure () {
90 ./configure ${EXTRA_OECONF}
93 do_compile () {
94 oe_runmake build
95 oe_runmake compile
98 do_stage () {
102 do_install () {
103 oe_runmake 'PKG_DIR=${D}' install-all
106 #do_install () {
107 # install -d ${D}${sbindir} ${D}${sysconfdir}/appWeb/lib \
108 # ${D}${libexecdir}/appWeb ${D}${libdir}
109 # install -m 0755 appWeb/appWeb ${D}${sbindir}/
110 # install -m 0644 appWeb/appWeb.conf ${D}${sysconfdir}/appWeb/
111 # install -m 0755 bin/${APPWEB_OS}/* ${D}${libexecdir}/appWeb/
112 # install -m 0755 lib/lib*.so* ${D}${sysconfdir}/appWeb/lib/
115 SRC_URI[md5sum] = "3fb255992b2af8f61c60a9706effbfa6"
116 SRC_URI[sha256sum] = "cc924ea10f77acae123194a33f46d8484642501cc6fe94b47491ecf3ad18419e"