1 DESCRIPTION
= "Anti Grain Geometry - A High Quality Rendering Engine for C++"
2 AUTHOR
= "mcseem@antigrain.com"
3 HOMEPAGE
= "http://www.antigrain.com"
5 LICENSE
= "AGG License"
6 DEPENDS
= "virtual/libx11 virtual/libsdl freetype"
10 SRC_URI
= "http://www.antigrain.com/${P}.tar.gz;name=archive"
13 inherit autotools pkgconfig
15 export SDL_CONFIG
=$
{STAGING_BINDIR_CROSS
}/sdl
-config
17 CFLAGS
+= " -I${STAGING_INCDIR} "
19 PACKAGES
=+ "${PN}-sdl ${PN}-x11"
21 FILES_$
{PN
}-sdl
= "${libdir}/libaggplatformsdl.so.*"
22 FILES_$
{PN
}-x11
+= "${libdir}/libaggplatformX11.so.*"
23 FILES_$
{PN
} = "${libdir}/libagg.so.* \
24 ${libdir}/libaggfontfreetype.so.*"
26 LEAD_SONAME
= "libagg.so"
28 EXTRA_OECONF
= "--x-includes=${STAGING_INCDIR}/usr/include --x-libraries=${STAGING_INCDIR}/usr/lib"
31 oe_libinstall
-a
-so libagg $
{STAGING_LIBDIR
}
32 oe_libinstall
-a
-so libaggfontfreetype $
{STAGING_LIBDIR
}
33 oe_libinstall
-a
-so libaggplatformX11 $
{STAGING_LIBDIR
}
34 oe_libinstall
-a
-so libaggplatformsdl $
{STAGING_LIBDIR
}
35 install
-m
0644 libagg.m4 $
{STAGING_DATADIR
}/aclocal
/
36 install
-d $
{STAGING_INCDIR
}/agg2
38 for f in font_freetype font_win32_tt gpc
40 install
-m
0644 $
{S
}/$f
/*.h $
{STAGING_INCDIR
}/agg2
/
44 headers
=`find .
-name
"*.h"`
47 install
-D
-m
0644 $f $
{STAGING_INCDIR
}/agg2
/$f
51 SRC_URI
[archive.md5sum
] = "0229a488bc47be10a2fee6cf0b2febd6"
52 SRC_URI
[archive.sha256sum
] = "ab1edc54cc32ba51a62ff120d501eecd55fceeedf869b9354e7e13812289911f"