ti-recipes: Add SECTION qualifiers to recipes
[openembedded.git] / recipes / ti / bitblit_svn.bb
blobd4ae18ce8e6542677021f375ede96ed66380d4d9
1 DESCRIPTION = "Low level 2D blitting/blending graphics acceleration services support on DM6446, OMAP3530 and OMAP-L137."
2 SECTION = "multimedia"
4 require ti-paths.inc
6 DEPENDS = "ti-codec-engine ti-dmai"
8 # Fetch source from svn repo
9 SRCREV = "2"
10 SRC_URI = "svn://gforge.ti.com/svn/${PN};module=trunk;proto=https;user=anonymous;pswd='' \
11 file://recent-linux.diff;patch=1 \
14 # Again, no '.' in PWD allowed :(
15 PV = "0+svnr${SRCPV}"
16 PR = "r1"
18 S = "${WORKDIR}/trunk/bitblit"
20 export LINUXLIBS_INSTALL_DIR="${STAGING_DIR_HOST}/usr"
21 export EXEC_DIR = "${D}${datadir}/ti/bitblit/"
23 CPPFLAGS_append = " -DPlatform_${PLATFORM}"
25 PACKAGE_ARCH = "${MACHINE_ARCH}"
27 do_compile() {
28 oe_runmake -e all
31 do_install() {
32 oe_runmake -e install