1 HOMEPAGE
= "http://linux.duke.edu/projects/yum/"
4 SRC_URI
= "http://linux.duke.edu/projects/yum/download/3.2/yum-${PV}.tar.gz \
7 file://yum-install-recommends.py \
8 file://extract-postinst.awk"
10 RDEPENDS_$
{PN
} = "python-rpm python-core python-iniparse python-urlgrabber \
11 python-shell python-re python-logging python-pickle \
12 python-netserver python-compression \
13 python-unixadmin python-xml python-sqlite3 \
14 python-textutils python-fcntl python-email \
17 S
= "${WORKDIR}/yum-${PV}"
21 do_compile_append
() {
22 sed
-e 's#
!/usr
/bin/python#
!$
{bindir
}/python#'
-e 's#
/usr
/share#$
{datadir
}#'
-i $
{S
}/bin/yum.py
23 sed
-e 's#
!/usr
/bin/python#
!$
{bindir
}/python#'
-e 's#
/usr
/share#$
{datadir
}#'
-i $
{S
}/bin/yum
-updatesd.py
26 do_install_append
() {
27 install
-d $
{D
}$
{bindir
}/
28 install $
{WORKDIR
}/extract
-postinst.awk $
{D
}$
{bindir
}/
29 install $
{WORKDIR
}/yum
-install
-recommends.py $
{D
}$
{bindir
}/
32 FILES_$
{PN
} += "${libdir}/python* ${datadir}/yum-cli"
34 SRC_URI
[md5sum
] = "711f518cb72a698ed98a21a374a4585e"
35 SRC_URI
[sha256sum
] = "8b3f300602ce021bf5202496b98271814935f45f3bf3c6730ba4e789b2f323c8"