python-pyrex: Rework DEPENDS updates
[openembedded.git] / recipes / xfce-base / exo_0.3.105.bb
blobeedbe10acb94574156022b681bf993af44122a59
1 DESCRIPTION="XFCE extensions and framework library with session management support"
2 DEPENDS = "libxfce4util hal liburi-perl-native python-native cairo"
3 SECTION = "x11"
4 PR = "r2"
6 inherit xfce46 python-dir
8 XFCE_VERSION = "4.6.1"
10 SRC_URI += " \
11 file://exo-0.3.105-iocharset.patch \
12 file://exo-no-tests.patch \
13 file://configure.patch \
16 # Note: Python checking is broken
17 do_configure_prepend() {
18 sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g ${S}/configure.in
21 FILES_${PN} += "${datadir}/xfce4/ \
22 ${PYTHON_SITEPACKAGES_DIR}/* \
23 ${prefix}/share/pygtk/2.0/defs/exo-0.3/exo.defs \
26 FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*/.debug/*"
28 SRC_URI[md5sum] = "ba87f84894498bf23ae39d849c55f98c"
29 SRC_URI[sha256sum] = "278f702d890c89bd3923ce1bdaf29bd9f2c800c2e4cfd9e902d99663bba337e5"