python-pyrex: Rework DEPENDS updates
[openembedded.git] / recipes / tcltk / tcl_8.5.8.bb
blob86302407c781b31500f9aa609473ab968af3fe3a
1 DESCRIPTION = "Tool Command Language"
2 HOMEPAGE = "http://tcl.sourceforge.net"
3 SECTION = "devel/tcltk"
4 LICENSE = "tcl"
5 PR = "r8"
7 SRC_URI = "\
8 ${SOURCEFORGE_MIRROR}/tcl/tcl${PV}-src.tar.gz \
9 file://confsearch.diff;striplevel=2 \
10 file://manpages.diff;striplevel=2 \
11 file://non-linux.diff;striplevel=2 \
12 file://rpath.diff;striplevel=2 \
13 file://tcllibrary.diff;striplevel=2 \
14 file://tclpackagepath.diff;striplevel=2 \
15 file://tclprivate.diff;striplevel=2 \
16 file://mips-tclstrtod.patch;striplevel=0 \
18 SRC_URI[md5sum] = "7f123e53b3daaaba2478d3af5a0752e3"
19 SRC_URI[sha256sum] = "6b090c1024038d0381e1ccfbd6d5c0f0e6ef205269ceb9d28bd7bd7ac5bbf4a7"
21 S = "${WORKDIR}/tcl${PV}/unix"
22 SYSROOT_PREPROCESS_FUNCS =+ "tcl_sysroot"
24 inherit autotools binconfig
26 EXTRA_OECONF = "--enable-threads"
28 do_compile_prepend() {
29 echo > ../compat/fixstrtod.c
30 sed -i -e 's:./tclsh :tclsh :g' Makefile
32 do_install() {
33 autotools_do_install
34 # Stage a few extra headers to make tk happy
35 install -d ${D}${includedir}/tcl-${PV}/generic
36 install -m 0644 ../generic/*.h ${D}${includedir}/tcl-${PV}/generic
37 install -m 0644 *.h ${D}${includedir}/tcl-${PV}/generic
38 install -d ${D}${includedir}/tcl-${PV}/unix
39 install -m 0644 *Unix*.h ${D}${includedir}/tcl-${PV}/unix/
40 rm -f ${D}${includedir}/regex.h
41 ln -sf tclsh8.5 ${D}${bindir}/tclsh
44 PACKAGES =+ "${PN}-lib"
46 FILES_${PN}-lib = "${libdir}/libtcl8.5.so.*"
47 FILES_${PN} += "${libdir}/tcl*"
48 FILES_${PN}-dev += "${libdir}/tclConfig.sh"
50 BINCONFIG_GLOB = "*Config.sh"
51 BBCLASSEXTEND = "native"
53 tcl_sysroot() {
54 sed -i 's:${includedir}/tcl-private:${STAGING_INCDIR}/tcl-${PV}:' tclConfig.sh