python-pyrex: Rework DEPENDS updates
[openembedded.git] / recipes / sdr / sdrshell_svn.bb
blobe5ceb13fa6184cf48da474f5a85a9c4abe85a48b
1 DESCRIPTION = "SDR-Shell is Qt GUI for the sdr-core (DttSP) Software Defined Radio"
2 LICENSE = "GPLv2"
4 DEPENDS = "dttsp"
6 inherit qmake qt3x11
8 SRCREV = "57"
9 PV = "${SRCREV}"
11 SRC_URI = "svn://sdr-shell.googlecode.com/svn/branches;module=sdr-shell-v2;proto=http \
12 file://gcc-43-fix.patch;striplevel=0"
13 S = "${WORKDIR}/sdr-shell-v2"
15 PARALLEL_MAKE = ""
17 do_configure_prepend() {
18 rm -f ${S}/sdr-shell
21 do_compile_prepend() {
22 sed -i -e s:OE_QMAKE_LINK:CXX:g ${S}/Makefile
25 do_install() {
26 install -d ${D}${bindir}
27 install -m 0755 ${S}/sdr-shell ${D}${bindir}