python-pyrex: Rework DEPENDS updates
[openembedded.git] / recipes / rxvt-unicode / rxvt-unicode_5.2.bb
blobd125d378694ad44a1bdf676e3290211ebf7a7297
1 SECTION = "x11/utils"
2 DEPENDS = "virtual/libx11 libxt libxft"
3 DESCRIPTION = "rxvt-unicode is a clone of the well known \
4 terminal emulator rxvt, modified to store text in Unicode \
5 (either UCS-2 or UCS-4) and to use locale-correct input and \
6 output. It also supports mixing multiple fonts at the \
7 same time, including Xft fonts."
8 LICENSE = "GPL"
9 SRC_URI = "http://dist.schmorp.de/rxvt-unicode/rxvt-unicode-${PV}.tar.bz2 \
10 file://signedchar.patch"
12 SRC_URI[md5sum] = "52664198e7c6a500dd9728b1a2c97e8a"
13 SRC_URI[sha256sum] = "6ce00673bb9be8ed172c41c9246689916e358d331eb24aa05f5d89db4dd23c82"
15 inherit autotools update-alternatives
17 PROVIDES = "virtual/x-terminal-emulator"
18 ALTERNATIVE_NAME = "x-terminal-emulator"
19 ALTERNATIVE_PATH = "${bindir}/rxvt"
21 CFLAGS_append = " -fpermissive"
23 EXTRA_OECONF = "--enable-menubar --enable-xim \
24 --enable-utmp --enable-wtmp --enable-lastlog \
25 --disable-strings --with-term=rxvt --enable-keepscrolling \
26 --enable-xft --with-name=rxvt --enable-frills \
27 --enable-swapscreen --enable-transparency \
28 --with-codesets=eu \
29 --enable-cursor-blink --enable-pointer-blank \
30 --enable-text-blink --enable-plain-scroll \
31 --enable-combining --enable-shared \
32 --enable-xgetdefault \
33 --with-x=${STAGING_LIBDIR}/.."
34 EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
35 'XLIB=-L${STAGING_LIBDIR} -lX11'"
37 do_configure () {
38 mv autoconf/configure.in . || true
39 rm autoconf/libtool.m4
40 libtoolize --force
41 autotools_do_configure
42 echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
43 echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
44 echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
45 echo '#define HAVE_XLOCALE 1' >> config.h
48 do_compile () {
49 if test -e ${S}/${HOST_SYS}-libtool; then
50 LIBTOOL=${S}/${HOST_SYS}-libtool
51 else
52 LIBTOOL=${S}/libtool
54 # docs need "yodl" and I have no idea what that is
55 oe_runmake -C src "LIBTOOL=$LIBTOOL"