python-pyrex: Rework DEPENDS updates
[openembedded.git] / recipes / opensp / opensp-native_1.5.bb
blobfe28a4c0e78925d6889815db9706547e37fda8c5
1 SECTION = "libs"
2 DEPENDS = ""
3 PR = "r2"
5 SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/OpenSP-${PV}.tar.gz \
6 file://m4.patch \
7 file://attributevalue.patch \
8 file://rangmap-fix.patch"
10 S = "${WORKDIR}/OpenSP-${PV}"
11 LICENSE = "MIT"
12 inherit autotools native gettext
14 EXTRA_OECONF = "\
15 --enable-default-catalog=${sysconfdir}/sgml/catalog \
16 --enable-default-search-path=${datadir}/sgml \
19 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/opensp-${PV}"
20 PACKAGES = ""
22 do_configure () {
23 gnu-configize
24 oe_runconf
27 do_stage () {
28 oe_libinstall -a -so -C lib libosp ${STAGING_LIBDIR}
29 install -d ${STAGING_INCDIR}/OpenSP
30 install -m 0644 ${S}/include/*.h ${STAGING_INCDIR}/OpenSP/
31 install -m 0644 ${S}/include/*.cxx ${STAGING_INCDIR}/OpenSP/
32 install -m 0644 config.h ${STAGING_INCDIR}/OpenSP/config.h
34 # Installs all the tools and symlink with another common name to each.
35 install -d ${STAGING_BINDIR_NATIVE}
36 for tool in nsgmls sgmlnorm spam spcat spent sx
38 echo installing $tool to ${STAGING_BINDIR_NATIVE}
39 install -m 0755 $tool/.libs/o$tool ${STAGING_BINDIR_NATIVE}
40 ln -sf o$tool ${STAGING_BINDIR_NATIVE}/$tool
41 done
44 SRC_URI[md5sum] = "87f56e79ae0c20397f4207d61d154303"
45 SRC_URI[sha256sum] = "987eeb9460185950e066e5db3b5fa531e53e213742b545288405552a5a7bb704"