python-pyrex: Rework DEPENDS updates
[openembedded.git] / recipes / opencv / opencv-dsp-acceleration_svn.bb
blob788e8e21ee0d7a8ecf32484f999b29228d2a59ff
1 LICENSE = "BSD"
2 DEPENDS = "ti-codec-engine ti-dsplib"
4 PV = "0+svnr${SRCPV}"
5 SRCREV = "128"
7 SRC_URI = "svn://opencv-dsp-acceleration.googlecode.com/svn/;proto=http;module=trunk \
8 http://focus.ti.com/lit/sw/sprc264/sprc264.zip;name=imglib \
11 SRC_URI[imglib.md5sum] = "97dca3f1612d7c35b3d3fe9f32ab3e0c"
12 SRC_URI[imglib.sha256sum] = "bf22c58cf81362ec3e7ed2d8debc39f00d1bfd0343094401cce2f928830858c1"
14 S = "${WORKDIR}/trunk/dsp_opencv"
16 require recipes/ti/ti-paths.inc
17 require recipes/ti/ti-staging.inc
19 export CROSS_COMPILE = "${TOOLCHAIN_PATH}/bin/${TARGET_PREFIX}"
20 export LINUXKERNEL_INSTALL_DIR = "${STAGING_KERNEL_DIR}"
21 export OPENCV_PATH = "${STAGING_INCDIR}"
22 export DSPLIB_PATH = "${DSPLIB_INSTALL_DIR}"
24 # You need to extract the imglib from the .exe manually and place it in /OE/tmp (or somewhere else and change the patch below)
25 export IMGLIB_PATH = "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}${installdir}/imglib_v201"
27 do_configure() {
28 echo "-l ${DSPLIB_INSTALL_DIR}/dsplib64plus.lib" >> ${S}/beagle/server/opencv_unitserver_evm3530/link.cmd
29 echo "-l ${IMGLIB_PATH}/lib/target/imglib2.l64P" >> ${S}/beagle/server/opencv_unitserver_evm3530/link.cmd
30 sed -e /DIR/d -e /PATH/d -i Rules.make
31 for i in $(find ${S} -name "*.mak" ; find ${S} -name "*.cmd") ; do
32 sed -i s:/media/disk/OE/work/ti/dsplib_v210:${DSPLIB_PATH}:g $i
33 sed -i s:/media/disk/OE/work/ti/imglib_v201:${IMGLIB_PATH}:g $i
34 done
36 # Add in build *FLAGS as well
37 for i in $(find ${S} -name "Makefile") ; do
38 sed -i -e 's:LD_FLAGS):LD_FLAGS) $(LDFLAGS):g' -e 's:C_FLAGS):C_FLAGS) $(CFLAGS):g' $i
39 done
42 do_compile() {
43 oe_runmake -e codec
44 oe_runmake -e server
45 oe_runmake -e library
46 oe_runmake -e app
49 do_install() {
50 oe_runmake -e install EXEC_DIR=${D}${datadir}/ti/opencv-dsp
53 FILES_${PN} += "${datadir}"