python-pyrex: Rework DEPENDS updates
[openembedded.git] / recipes / mplayer / mplayer-maemo_svn.bb
blob83229af949dae31641bd269fdb8366f4bd4cebac
1 DESCRIPTION = "Open Source multimedia player."
2 SECTION = "multimedia"
3 PRIORITY = "optional"
4 HOMEPAGE = "http://www.mplayerhq.hu/"
5 DEPENDS = "virtual/libsdl xsp libmad zlib libpng jpeg liba52 freetype fontconfig alsa-lib lzo ncurses lame libxv virtual/libx11"
7 DEFAULT_PREFERENCE_avr32 = "-1"
9 SRCREV = "6952"
10 PV = "0.0+1.0rc1+svnr${SRCPV}"
11 PE = "1"
12 PR = "r2"
14 RCONFLICTS_${PN} = "mplayer"
16 RDEPENDS_${PN} = "mplayer-common"
17 LICENSE = "GPL"
18 SRC_URI = "svn://garage.maemo.org/svn/mplayer/;module=trunk;proto=https \
19 file://Makefile-codec-cfg.patch \
20 file://pld-onlyarm5.patch \
21 file://makefile-nostrip.patch \
22 file://motion-comp-pld.patch \
23 file://cfg-common-position.patch "
25 # This is required for the collie machine only as all stacks in that
26 # machine seem to be set to executable by the toolchain. If someone
27 # discovers this is more general than please make this more general
28 # ie. for all armv4 machines.
29 SRC_URI_append_collie = "file://disable-executable-stack-test.patch"
31 PACKAGE_ARCH_collie = "collie"
33 PARALLEL_MAKE = ""
35 S = "${WORKDIR}/trunk"
37 PACKAGES =+ "mencoder"
39 FILES_${PN} = "${bindir}/mplayer ${libdir}"
40 FILES_mencoder = "${bindir}/mencoder"
42 inherit autotools pkgconfig
44 EXTRA_OECONF = " \
45 --prefix=/usr \
46 --mandir=${mandir} \
47 --target=${TARGET_SYS} \
49 --enable-mencoder \
50 --disable-gui \
51 --enable-largefiles \
52 --disable-linux-devfs \
53 --disable-lirc \
54 --disable-lircc \
55 --disable-joystick \
56 --disable-vm \
57 --disable-xf86keysym \
58 --disable-tv \
59 --disable-tv-v4l2 \
60 --enable-v4l2 \
61 --disable-tv-bsdbt848 \
62 --enable-rtc \
63 --enable-network \
64 --disable-winsock2 \
65 --disable-smb \
66 --disable-live \
67 --disable-dvdnav \
68 --disable-dvdread \
69 --disable-cdparanoia \
70 --enable-freetype \
71 --disable-unrarlib \
72 --disable-menu \
73 --enable-sortsub \
74 --disable-fribidi \
75 --disable-enca \
76 --disable-macosx \
77 --disable-macosx-finder-support \
78 --disable-macosx-bundle \
79 --disable-ftp \
80 --disable-vstream \
82 --disable-gif \
83 --enable-png \
84 --enable-jpeg \
85 --disable-libcdio \
86 --disable-liblzo \
87 --disable-qtx \
88 --disable-xanim \
89 --disable-real \
90 --disable-xvid \
91 --disable-x264 \
93 --disable-libavutil_so \
94 --disable-libavcodec_so \
95 --disable-libavformat_so \
96 --disable-libpostproc_so \
98 --enable-tremor-low \
100 --disable-speex \
101 --disable-theora \
102 --disable-faac \
103 --disable-ladspa \
104 --disable-libdv \
105 --enable-mad \
106 --disable-toolame \
107 --disable-twolame \
108 --disable-xmms \
109 --disable-mp3lib \
110 --enable-libmpeg2 \
111 --disable-musepack \
113 --disable-gl \
114 --disable-vesa \
115 --disable-svga \
116 --enable-sdl \
117 --disable-aa \
118 --disable-caca \
119 --disable-ggi \
120 --disable-ggiwmh \
121 --disable-directx \
122 --disable-dxr2 \
123 --disable-dxr3 \
124 --disable-dvb \
125 --disable-dvbhead \
126 --disable-mga \
127 --disable-xmga \
128 --enable-xv \
129 --disable-xvmc \
130 --disable-vm \
131 --disable-xinerama \
132 --enable-x11 \
133 --enable-fbdev \
134 --disable-mlib \
135 --disable-3dfx \
136 --disable-tdfxfb \
137 --disable-s3fb \
138 --disable-directfb \
139 --disable-zr \
140 --disable-bl \
141 --disable-tdfxvid \
142 --disable-tga \
143 --disable-pnm \
144 --disable-md5sum \
146 --enable-alsa \
147 --enable-ossaudio \
148 --disable-arts \
149 --disable-esd \
150 --disable-polyp \
151 --disable-jack \
152 --disable-openal \
153 --disable-nas \
154 --disable-sgiaudio \
155 --disable-sunaudio \
156 --disable-win32waveout \
157 --enable-select \
159 --disable-ass \
162 EXTRA_OECONF_append_armv6 = " --enable-armv6 --enable-arm-vfp"
163 EXTRA_OECONF_append_armv7a = "--enable-armv6 --enable-arm-vfp"
165 #build with support for the iwmmxt instruction and pxa270fb overlay support (pxa270 and up)
166 #not every iwmmxt machine has the lcd connected to pxafb, but building the module doesn't hurt
167 MY_ARCH := "${PACKAGE_ARCH}"
168 PACKAGE_ARCH = "${@base_contains('MACHINE_FEATURES', 'iwmmxt', 'iwmmxt', '${MY_ARCH}',d)}"
170 MY_TARGET_CC_ARCH := "${TARGET_CC_ARCH}"
171 TARGET_CC_ARCH = "${@base_contains('MACHINE_FEATURES', 'iwmmxt', '-march=iwmmxt -mtune=iwmmxt', '${MY_TARGET_CC_ARCH}',d)}"
173 EXTRA_OECONF_append = " ${@base_contains('MACHINE_FEATURES', 'iwmmxt', '--enable-pxa --enable-iwmmxt', '',d)} "
174 EXTRA_OECONF_append = " ${@base_contains('MACHINE_FEATURES', 'x86', '--enable-runtime-cpudetection', '',d)} "
176 FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O4 -ffast-math"
177 FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations -ftree-vectorize -fomit-frame-pointer -O4 -ffast-math"
178 BUILD_OPTIMIZATION = "${FULL_OPTIMIZATION}"
181 do_configure() {
182 sed -i 's|/usr/include|${STAGING_INCDIR}|g' ${S}/configure
183 sed -i 's|/usr/lib|${STAGING_LIBDIR}|g' ${S}/configure
184 sed -i 's|/usr/\S*include[\w/]*||g' ${S}/configure
185 sed -i 's|/usr/\S*lib[\w/]*||g' ${S}/configure
187 ./configure ${EXTRA_OECONF}
190 do_compile () {
191 oe_runmake