1 DESCRIPTION
= "Open Source multimedia player."
4 HOMEPAGE
= "http://www.mplayerhq.hu/"
5 DEPENDS
= "virtual/libsdl xsp libmad zlib libpng jpeg liba52 freetype fontconfig alsa-lib lzo ncurses lame libxv virtual/libx11"
7 DEFAULT_PREFERENCE_avr32
= "-1"
10 PV
= "0.0+1.0rc1+svnr${SRCPV}"
14 RCONFLICTS_$
{PN
} = "mplayer"
16 RDEPENDS_$
{PN
} = "mplayer-common"
18 SRC_URI
= "svn://garage.maemo.org/svn/mplayer/;module=trunk;proto=https \
19 file://Makefile-codec-cfg.patch \
20 file://pld-onlyarm5.patch \
21 file://makefile-nostrip.patch \
22 file://motion-comp-pld.patch \
23 file://cfg-common-position.patch "
25 # This is required
for the collie machine only as all stacks in that
26 # machine seem
to be set
to executable by the toolchain.
If someone
27 # discovers this is more general than please make this more general
28 # ie.
for all armv4 machines.
29 SRC_URI_append_collie
= "file://disable-executable-stack-test.patch"
31 PACKAGE_ARCH_collie
= "collie"
35 S
= "${WORKDIR}/trunk"
37 PACKAGES
=+ "mencoder"
39 FILES_$
{PN
} = "${bindir}/mplayer ${libdir}"
40 FILES_mencoder
= "${bindir}/mencoder"
42 inherit autotools pkgconfig
47 --target=${TARGET_SYS} \
52 --disable-linux-devfs \
57 --disable-xf86keysym \
61 --disable-tv-bsdbt848 \
69 --disable-cdparanoia \
77 --disable-macosx-finder-support \
78 --disable-macosx-bundle \
93 --disable-libavutil_so \
94 --disable-libavcodec_so \
95 --disable-libavformat_so \
96 --disable-libpostproc_so \
156 --disable-win32waveout \
162 EXTRA_OECONF_append_armv6
= " --enable-armv6 --enable-arm-vfp"
163 EXTRA_OECONF_append_armv7a
= "--enable-armv6 --enable-arm-vfp"
165 #build with support
for the iwmmxt instruction
and pxa270fb overlay support
(pxa270
and up
)
166 #
not every iwmmxt machine has the lcd connected
to pxafb
, but building the module doesn't hurt
167 MY_ARCH
:= "${PACKAGE_ARCH}"
168 PACKAGE_ARCH
= "${@base_contains('MACHINE_FEATURES', 'iwmmxt', 'iwmmxt', '${MY_ARCH}',d)}"
170 MY_TARGET_CC_ARCH
:= "${TARGET_CC_ARCH}"
171 TARGET_CC_ARCH
= "${@base_contains('MACHINE_FEATURES', 'iwmmxt', '-march=iwmmxt -mtune=iwmmxt', '${MY_TARGET_CC_ARCH}',d)}"
173 EXTRA_OECONF_append
= " ${@base_contains('MACHINE_FEATURES', 'iwmmxt', '--enable-pxa --enable-iwmmxt', '',d)} "
174 EXTRA_OECONF_append
= " ${@base_contains('MACHINE_FEATURES', 'x86', '--enable-runtime-cpudetection', '',d)} "
176 FULL_OPTIMIZATION
= "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O4 -ffast-math"
177 FULL_OPTIMIZATION_armv7a
= "-fexpensive-optimizations -ftree-vectorize -fomit-frame-pointer -O4 -ffast-math"
178 BUILD_OPTIMIZATION
= "${FULL_OPTIMIZATION}"
182 sed
-i 's|
/usr
/include|$
{STAGING_INCDIR
}|g' $
{S
}/configure
183 sed
-i 's|
/usr
/lib|$
{STAGING_LIBDIR
}|g' $
{S
}/configure
184 sed
-i 's|
/usr
/\S
*include[\w
/]*||g' $
{S
}/configure
185 sed
-i 's|
/usr
/\S
*lib
[\w
/]*||g' $
{S
}/configure
187 .
/configure $
{EXTRA_OECONF
}