python-pyrex: Rework DEPENDS updates
[openembedded.git] / recipes / linux / linux-nios2_2.6.34.bb
blob73448c97cb04c89f7dc1a637bdaccbeabb1d90b4
1 require linux.inc
3 PR = "r0"
5 S = "${WORKDIR}/linux-2.6"
7 # For nios2 the source comes from sopc.et.ntust.edu.tw, but as this one is very slow
8 # a tarball is placed at opensource.axon.tv
9 #SRC_URI_nios2 = "git://sopc.et.ntust.edu.tw/git/linux-2.6.git;branch=nios2mmu;protocol=http;tag=a32ca88c4f3f3850c5c9789db2afab2530c6856d;protocol=http \
10 SRC_URI_nios2 = "ftp://opensource.axon.nl/mirror/git_sopc.et.ntust.edu.tw.linux-2.6.git_a32ca88c4f3f3850c5c9789db2afab2530c6856d.tar.gz;name=nios2tarball \
11 file://defconfig \
14 # nios2 checksums
15 SRC_URI[nios2tarball.md5sum] = "ad27c6ddfe5b2bb0f81968c0155d072d"
16 SRC_URI[nios2tarball.sha256sum] = "7c99c5ee4bf26d08fde030c605c618454984dba5ae79c298064228ab0053e60f"
18 KERNEL_IMAGETYPE = "zImage"
20 do_configure() {
21 rm -f ${S}/.config
23 if [ ! -e ${WORKDIR}/defconfig ]; then
24 die "No default configuration for ${MACHINE} available."
27 cp ${WORKDIR}/defconfig ${S}/.config
29 # echo "CONFIG_INITRAMFS_SOURCE=\"${DEPLOY_DIR_IMAGE}/initramfs_root.cpio\"" >> ${S}/.config
30 # sed -e '/CONFIG_INITRAMFS_SOURCE/d' '${WORKDIR}/defconfig' >>'${S}/.config'
33 yes '' | oe_runmake oldconfig