python-pyrex: Rework DEPENDS updates
[openembedded.git] / recipes / linux / linux-magicbox_2.6.18.6.bb
blob32953341c0cdda46330d36b19e9afa767ff278de
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for Magicbox ver 1.1 and 2.0 router boards"
3 LICENSE = "GPLv2"
4 PR = "r2"
5 DEPENDS = "u-boot"
7 COMPATIBLE_MACHINE = "magicbox"
9 KERNEL_CCSUFFIX = "-3.4.4"
11 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
12 file://000-fix-makefile.patch \
13 file://001-magicbox-board-2.6.18.patch \
14 file://002-magicbox-mtd-map-2.6.18.patch \
15 file://010-load-ramdisk-even-if-rootdev-equals-ramdisk.patch \
16 file://magicbox2-ide-cf_2.6.18.patch \
17 file://squashfs3.1-patch;apply=yes \
18 file://squashfs-lzma-support.patch \
19 file://kernel-2.6.18-layer7-2.6.patch \
20 file://config-2.6.18-magicbox2\
24 S = "${WORKDIR}/linux-${PV}"
26 inherit kernel
29 FILES_kernel-image = "/boot/zImage.elf"
31 export OS = "Linux"
32 ARCH = "ppc"
33 KERNEL_OUTPUT = "arch/ppc/boot/images/zImage.elf"
38 do_configure_prepend() {
39 install -m 0644 ${WORKDIR}/config-2.6.18-magicbox2 ${S}/.config
43 do_install_append () {
44 #need ppc platforms includes + friends in order for external kernel modules to compile as headers as still split
46 install -d $kerneldir/arch/
47 cp -pPR arch/ppc $kerneldir/arch/
48 cp -pPR arch/powerpc $kerneldir/arch/
50 cp -pPR include/asm-powerpc $kerneldir/include/
51 cp -pPR include/asm-ppc $kerneldir/include/
56 do_install_append () {
57 install -d ${DEPLOY_DIR}/images
58 install -m 0755 arch/ppc/boot/images/zImage.elf ${DEPLOY_DIR}/images/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}.elf
59 install -m 0755 vmlinux ${DEPLOY_DIR}/images/
60 powerpc-${TARGET_OS}-objcopy -O binary -R .note -R .comment -S ${DEPLOY_DIR}/images/vmlinux ${DEPLOY_DIR}/images/linux.bin
61 gzip -f -9 ${DEPLOY_DIR}/images/linux.bin
62 mkimage -A ppc -O linux -T kernel -C gzip -a 0 -e 0 -n "ppc405"+${PV} -d ${DEPLOY_DIR}/images/linux.bin.gz ${DEPLOY_DIR}/images/uImage-${PV}-${MACHINE}-${DATETIME}.bin
63 rm ${DEPLOY_DIR}/images/vmlinux
64 rm ${DEPLOY_DIR}/images/linux.bin.gz
70 pkg_postinst_kernel () {
71 true
74 pkg_postrm_kernel () {
75 true
78 SRC_URI[md5sum] = "80812ae14dca35b3630883a96531674e"
79 SRC_URI[sha256sum] = "09a788b1bb0ce040c28180f5b2834f5c5d00efdf76b2ea2d071c9b010bf322e7"