python-pyrex: Rework DEPENDS updates
[openembedded.git] / recipes / linux / linux-leviathan_git.bb
blob25f7fb03e270865bc9040d08e7d86085b7f4a9d8
1 require linux.inc
2 DEPENDS += "android-image-utils-native"
4 PV = "2.6.32+${PR}+gitr${SRCREV}"
5 PR = "r22"
7 COMPATIBLE_MACHINE = "htcdream"
8 CMDLINE = "console=tty1 root=/dev/mmcblk0p1 rootdelay=8 fbcon=rotate:1 panic=30 mem=110M"
10 SRCREV = "013075354e0b533991650ec756605ad4731e6a0c"
12 SRC_URI = "\
13 git://gitorious.org/htc-msm-2-6-32/leviathan-incoming.git;protocol=git;branch=android-msm-2.6.32-rebase \
14 file://defconfig \
16 S = "${WORKDIR}/git"
18 do_deploy_append() {
19 if [ ! -e empty.gz ];then
20 if [ ! -e empty ];then
21 touch empty
23 gzip empty
25 mkbootimg --kernel ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_BASE_NAME}.bin \
26 --ramdisk empty.gz \
27 --cmdline "${CMDLINE}" \
28 --output ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_BASE_NAME}.fastboot