python-pyrex: Rework DEPENDS updates
[openembedded.git] / recipes / libdotconf / libdotconf_1.0.13.bb
blob077d1f139794c943730c44ab1a7d9fc3904c08d6
1 DESCRIPTION = " dot.conf is an easy to use and powerful configuration file parser library"
2 HOMEPAGE = "http://www.azzit.de/dotconf/"
3 LICENSE = "LGPLv2"
5 PR = "r0"
7 inherit autotools
9 SRC_URI = "http://www.azzit.de/dotconf/download/v1.0/dotconf-${PV}.tar.gz \
10 file://srcMakefile.am_00.patch"
12 S = "${WORKDIR}/dotconf-${PV}"
14 do_install() {
15 install -d ${D}${libdir}
16 install -d ${D}${includedir}
18 install -m 0644 ${S}/src/dotconf.h ${D}${includedir}
19 oe_libinstall -C src -so libdotconf ${D}${libdir}
22 do_stage() {
23 install -m 0644 ${S}/src/dotconf.h ${STAGING_INCDIR}/
24 oe_libinstall -C src -so libdotconf ${STAGING_LIBDIR}/
27 SRC_URI[md5sum] = "bbf981a5f4a64e94cc6f2a693f96c21a"
28 SRC_URI[sha256sum] = "8955fad7d9e7aef36f7a82f9577c3ae4901db1ded6ce57aec0d93e39c8899b65"